Servers by jDrones

Pixhawk 2.4.8 firmware error not downloading on any version of mission planner please help!

(Ali srour) #1

(Ali srour) #2

i tried to download firmware arducopter on several versions of mission planner and all leads to similar errors,
and i cant know why please help my pixhawk is new…
i tried to format sd card several times and i tried to force bootloader also and it didnt work as well by pressing the switch on start please guide me through …
the only way the firmware was downloaded is by changing the mission planner to Apm planner 2 in which i could download firmware , but i need to download the firmware on the latest version of mission planner please help!!

(Nashnir) #3

You can download the firmware directly from their website and the update using the file in Mission Planner. Does that work?

(Ali srour) #4

please can you provide links or specific details about this , i dont know any other way than mission planner .
i can download the firmware from APM planner 2.0.15 but the idea is i want it to work with mission planner , i want the firmware to be installed from mission planner

(Ali srour) #5

if i downloaded the firmware from APM planner i would be unable to access my log file on mission planner or on APM planner…

(Dave) #6

Download the .apj file from here and use the “Load Custom Firmware” option in Mission Planner.
http://firmware.ardupilot.org/Copter/stable/fmuv2/

If that doesn’t work try using QGroundControl to install the latest stable version of Arducopter. If succesful then use Mission Planner going forward.

1 Like
(Ali srour) #7

I managed to download the firmware from APM planner and i can work from there with mission planner right?
meanin using APM planner to download firmware to pixhawk and then using mission planner to extract logfiles and do the mission stuff and all calibrations right ?

(Dave) #8

Yes, but why are you using APM planner at all?

(Ali srour) #9

Since i am unable to download the copter firmware from mission planner due to an error that i dont know and you can find it in the pictures.