Pixhawk 2.4.8 Board Voltage reading

I’m using a pixhawk1 version 2.4.8 with the latest firmware.
I have an issue :slight_smile:

  • Powering up the pixhawk via the power connector using the BEC / current sensor the board voltage is roughly 4.2 to 4.3 volts, a measure with a multimeter on the connectors pins I read 5V
    This happens with two different boards that work well.
    Clearly I needed to switch of the Arming Safety option for the board voltage.

There are some suggestions ?

Best Regards

What does it indicate from USB power only?

Check the Pixhawk schematics and the voltage ratings. The +5V (or more) on the servo pins goes through diodes and IC’s to reach the measuring point and the 3.3V converter towards microprocessors, so voltage will drop slightly.

I have the same problem

I did these checks for voltages using a multimeter on power connector (attached image for pin out)

Pin 1 and 2 : OK, 5 Volts
Pin 3 : 0V its ok , no current is running through the pover converter
Pin 4 : 1.5V , this value is OK ? I don’t know
Pin 4 and 5 are the reference GND

Then I tried to power up the system via power module using a 4S lipo
the valure for Board Voltage is

The status is really better and the Arming is OK

I tried to power up the board with the servo rail the result is

The arming is OK

What I did versus the tests on yesterday is to unplug and then replug all the connectors.

What do you think about the described behavior ?


This is the behavior

Best Regards