Pixhawk 2.1 X8 arming motor check


Nice to have a lot of people with the same interests here - I hope someone can give me some hints now.

I´ve troubles at a final stage of my new copter.

I already done all calibrating on my Pixhawk 2.1 via Mission Controller (Version 1.3.49 with APM Copter 3.5.2) - it´s a X8 with Flame 100 ESCs and U7490k motors. Everything is working and I get a good GPS signal - I can press the safety switch and everything´s correct, but I´m not able to arm - doesn´t matter if I´m going over Mission Planner or just over the remote.
When I do the Kompass/Motor Calibration only the 4 motor on top spin, but the others on the bottom side don´t react. At frame type there is the correct value: X and OctoQuad.
Next is that the motors are spinning in the same direction.
If I go to motor test nothing happens - no motor reacts.

I´ve already checked all ESCs, Motors seperate and they´re working.

I´ve tried to start from the very beginning and put up another vehicles Firmware on the Pixhawk and then started from the very beginning. Same on Mission Planner Software.

Copter is in stabilize mode - so that´s not the failure.

There are no errors shown.

I use a Futuba 14SG - strange thing is that the throttle zero is on top and full throttle is on bottom.

I hope someone of you can give me some hint´s what else I can do.

Kindest regards,



I´ve just tried another sender and receiver - put up a SUMO Signal on my MZ-24 Pro and used a GR-24 and now all motors are spinning.

I can arm and everything - motor test still won´t work. Kompass/motor calibration works well.

I´ve checked the connections a couple of times, but still all motors are spinning into the same direction.

Every move on sender takes between 0,5 and 1,5 seconds to be recognized.

Kindest regards,


" but still all motors are spinning into the same direction." normally you just swap the motor wires to reverse them or use the programer for the esc’s.