Pixhawk 2.1 with Futuba SG14 - Unpredictable Mystery!

Okay here is what happened!

  1. We power up all the devices.
  2. Switch ON radio Tx
  3. Arm the Safety Switch.
  4. Slowly increase the Throttle

All fine now…
Suddenly, the Quad goes full power, blasting all the motors and Mission Planner connected via Telemetry says " No RC Input". No controls work, Disarm sequence not identified.
And Finally Stopped the erratic behavior by pressing the Safety switch on the HERE GPS.

Thank God, for the Motors didn’t have any props, Had it been in place, I still what our posistion would have been! This sort of encounter is quite new, as the same configuration worked for us many times in the past.

Now Comes the Investigation part, We took the Quad back, Reflashed the pixhawk 2.1 with firmware and ran the Wizard. Now, the Pixhawk doesn’t even recognize the Futuba RC reciever!
However, when we connected an alternate model Avionic Radio System, the pix was able to identify it.

What Could be possibly wrong!?

Quad Details

Tarot 650 Sport Frame
Emax MT4114-340KV - 15" props
Hobbywing 30A ESC
Pixawk 2.1 with Here+ GPS ( Firmware: APM:Copter:Quad: 3.5.3)
Battery Tattu - 6S- 1000mAh

Radio - Futuba 14SG as TX and R7008SB as the Rx.

Your power sequence is wrong, you should power the transmitter TX first, before powering any other radios.

Tried that as well, Still No joy! :frowning:

the pixhawk is detecting your receiver going into failsafe and attempting to RTL, post a log and check your throttle failsafe value.

Generally for the Pixhawk the throttle channel should be reversed on the transmitter.(Channel 3) for Futaba. Please insure this.

We use that receiver and transmitter exclusively and that could be your issue.

Though not related, know that the R7008SB is a “Transceiver” it sends telemetry back to the transmitter and as such draws more power then a non-telemetry receiver. it may overwhelm a standard 3DR power type dongle causing low voltage to the FMU. check and power accordingly.