Pixhawk 2.1 with Edison board, Serial 2 & 3 do not work

While trying to integrate a Lidar with the Pixhawk 2.1, I kept getting “Bad Lidar Health” and no rangefinder data. I attempted the configure on both Serial 2 & 3 ports.

When I removed the Edison board, the lidar worked. Did this test twice with the exact same setup, and got the same results.

Is there a configuration that needs to be changed when the Edison board is installed?

Need some help here ProfiCNC.

The Edison uses serial 2, so if it’s installed you can’t use serial 2. Serial 3 is gps 1.

Thanks, James!

Yep. I just read that on the ArduPilot website. However, that seems to only be true when SERIAL2_PROTOCOL is set to 1 (Mavlink). I have it set to 9 (Lidar). Does this not matter?

Also, my mistake, I meant to say we’ve tried the Lidar on Serial 2 & 4.

The Edison serial is hardwired, so if you want to use serial 2 you need to remove it.
Serial 4 should work. I’d suggest just using tx, rx and gnd though, and separate 5v to the lidar.