Pixhawk 2.1 Throttle Calibration not working - motors wont spin need help!

After installing my Pixhawk 2.1 into my UAV clouds everything was fine up until I had to calibrate my controller to mission planner. I am using a Taranis X9D Transmitter with a X8R receiver. My receiver is bound and is plugged up properly to my Pixhawk through the RCin port and Sbus port on my X8R receiver. The Tx and Rx are properly bound as I can plug up a servo directly to the Rx and it works. The firmware I have on my Pixhawk is Arduplane 3.8.5(latest version). UAV clouds is a v-tail plane as well and I have setup my inputs into Pixhawk and my radio as needed. I don’t know what I could be missing. Power wise I have made sure that the Pixhawk is powered by a battery using the power brick mini so it has plenty of current. Any tips would be greatly appreciated. For some reason it seems that Pixhawk is not responding to my Rx and I don’t have a clue why. At this point it looks like I need to start over, redo firmware, reconnect everything and possibly even redo firmware possibly on my Tx. Thanks guys.

Here is an image of what I am currently receiving in the calibration window.

Do you have any jumper set on the X8R ?
What is the mode set on your radio ?

Hey thanks for the reply! Because its an X8R it’s in D16 and I have it set from channels 1-16 just to take advantage of the channels. Nothing else is connected to my X8R just the Pixhawk from its RCin port. The radio I am using is in Mode 2 so nothing fancy here and I haven’t changed really anything just the channel lineup as I stated in my first post. I have a Spektrum Tx and Rx and just to test it out I’m gonna run that up later to see if I can get a connection even though I don’t intend on using my Spektrum Tx for FPV.

Here are just a few images to reaffirm what is going on. I also just setup a new model in my controller and I don’t have a failsafe set yet. Still no progress. The PDB I have I might rip it out and just solder up a new connector to take it out of the setup even though it should have nothing to do with it. If I try and remove the ESC connector from my Pixhawk once everything is turned on and I plug the ESC lead into my Rx the motors then beep and arm confirming connection, but if I plug it back into the Pixhawk turn everything off and try it again nothing from the motors. My Pixhawk unit is flashed properly as well so I am at a loss on this one. Thanks.

img1: http://prntscr.com/jhwh85
img2: http://prntscr.com/jhwhde
img3: http://prntscr.com/jhwhm8

So with no output connected to your Pixhawk 2.1 you are able to calibrate the radio with PM ?

With outputs 1,2 and 4 connected the servo works but if you connect your esc to output 3 the other servo stop to move ?

Sorry for the confusion. Just as a test I ran my ESC directly to my Rx. No channels on my Pixhawk work Aileron, Rudder, throttle nothing works while being plugged up to the Pixhawk.