Pixhawk 2.1 set up problems

I am building the DJI Flamewheel F550 hexacopter using a Pixhawk 2.1, Here GPS, FreSky X8R receiver , Taranis X9D plus transmitter and generic SiK telemetry radios.

I am getting nowhere with trying to set up the system using Mission Planner (and I’ve tried qgroundcontrol) because of the following issues:
1 - the Here external magnetometer won’t calibrate (the onboard units seem to calibrate OK and GPS is fine)
2 - the telemetry radios connect to each other OK judging by the steady green lights on each unit but no information flows to/from the Pixhawk 2.1
3 - on the radio calibration page of Mission Planner nothing happens - the green bars stay still no matter what I do

I’ve tried troubleshooting with some elementary steps, i.e all wiring appears correct, the receiver is properly bound to the transmitter and is emitting pulses on the SBUS output, I’ve reloaded the firmware several times (including intermediate steps of loading rover firmware to ensure complete erasure of data). I haven’t got much hair and what’s left is rapidly disappearing - please help before I go completely bald.


One step at a time.
Can you connect with USB and get data from the Pixhawk displayed in Mission Planner?
Make sure you are only connecting with USB first with no telemetry radios.

Can you confirm the X8R is working? Put a servo on the standard PWM output for say throttle and confirm it works. What mode is the X8R bound to the Taranis?

Peal complexity away to troubleshoot one issue at a time.

Thanks for your quick response. I’ve set about further analysis of my problems and summarise where I’ve got to thus:

  • USB connection between MP and Pixhawk 2.1 works fine and I can see attitude changes of the copter shown on screen

  • I’ve confirmed X8R is working and have solved the RC issue - I had set up the transmitter to only output channels 9 to 16 so it wasn’t sending any output for channels 1 - 8 :blush: Rectifying this enabled calibration of the RC inputs in MP

  • I’ve confirmed that the telemetry radios are connecting to each other and are operating with the same parameters as shown in the MP configuration screen - I’m able to change parameters on the ground unit and copy to the remote unit. With just the radios connected (i.e. no USB cable) I press the ‘Connect’ button in MP and get a window indicating that Mavlink is trying to connect - this then times out after 30 seconds with a ‘No heartbeat pulse’ error. I’ve double checked the wiring between the remote unit and Pixhawk 2.1 and it is correct so I’m stuck on this problem at the moment and don’t know what to try or where to look next.

  • Calibration of the external compass - I’ve left this problem in the hope that I could get the telemetry link working so that I could wave the copter around free of a USB cable when trying to calibrate.

Any help with the telemetry radio problem would be most welcome.


Check the COM port that MP is using? I’ve had a similar experience when switching between USB cable and telemetry radio, the Windows COM port number changes and MP defaults to the previous one.

Thanks for your comment Anthony - I understand what you mean and have found a few issues with the com port.

I have made progress and have got the radios connecting and relaying data from drone to MP at last. I found that I had incorrectly swapped RX and TX connections on the airborne radio (it has a 4 wire connection to the 6 wire Pixhawk so I had to cut and solder wires). Having corrected the miswiring I still then had to connect the airborne radio to my PC via an FDTI board in order to update its firmware and check all the parameters (something that a video on YouTube had suggested). At last it seemed to be working though a little flakey and needing the MP based radio to be up and running before powering up the drone radio in order for them to connect. I’m a little wary but after a lot of effort I seem to be getting some results. It seems that the chain of devices and parameters that need to be just right for the radios to work properly is rather challenging!

Now if the radio link proves to be reliable I can address the issue of getting the compasses calibrated.


Just as an update to anyone who might be interested, the telemetry radio system now works fine provided I power up the GC unit before the copter. Still haven’t sorted out the compass issue but have carried out a test flight and with great help from Anubis on this site have established that the HERE magnetometer may be malfunctioning in the Z-axis. So I’m looking at how best to add an external magnetometer to replace that of the HERE unit. Any ideas are welcome.


1 Like

As a final update I’ve added a LIS3MDL magnetometer and disabled detection of the defective HERE mag. I now have good heading data and have solved all the issues that started me off on this thread - thanks are due to the many people on this forum that have directly or indirectly given valuable assistance.