Pixhawk 2.1 + Here+ - Compass Copter 3.5.4

Hi there,
I have just recently setup two rigs with the Pixhawk 2.1 + Here+ - Compass.
On setting up and calibrating at the local test field everything was all well.
However, both rigs went out on different jobs in two different sited, one in Scotland and one in England.

Both the Pilots reported they could not carry out the jobs as the compass were acting up. On return I took the rigs to the test field, re-calibrated and sure enough, both rigs showed erratic compass behaviour.
The heading would wander about on each boot up. Sometimes 45, 90 and 180 -degrees out. this was strange that two rigs acted almost the same.

Upon return to the office I discovered the discussion on Github.[Cube/Here GPS heading off by 90deg]Cube/Here GPS heading off by 90deg looked to be the exact problems I see.

So as a test, I pulled a new Pixhawk 2 from stock, flashed copter 3.5.4.
No external compass, calibrate
Compass #1 and Compass #2 both internal, works good. Getting 0-degrees dead North.
Compass#1 offsets:- x:64, Y:-117, Z:-55
Compas#2 offsets:- x:-255, y:19, Z:107
MagZ 508 MagZ2 600
Connected external Here Compass,
Compass #1 now becomes External #2 and # 3 both internal.

Im going to stop here as I need to confirm this is correct.

Compass #1 now becomes External #2 and # 3 both internal.
As with the Here + after calibration #2 always changes to EXTERNAL.

Is this correct as the Here+ does have 3 x compass.


Try setting parameter COMPASS_TYPEMASK to 15392. That will disable the LIS3MDL in the here that was always disabled by default until 3.5.4. Now it’s enabled by default. That could be messing things up.

Thanks, I will give that a go.

I spent a good few hours down at the test field today.
With the Here + I tried COMPASS_TYPEMASK to 15392 and COMPASS_TYPEMASK parameter to disable the QMC5883L driver as Randy did. Yet I could not get the Here+ align correctly. Calibrations passed but same issue.

I swapped out the Here + for the standard Here and, COMPASS_TYPEMASK back to the default 32 and it worked fine.

I will be carrying out more tests but for two systems doing the same thing, there must be a underlying issue.

this work for me with here standart
anything more tested?

Not as yet, I hope to get back on this by end of this week / beginning next week.

Was there any more testing or conversation about these issues? Having compass issues with Here+ also.

I’m also experiencing issues with compass heading on Pixhawk2.1 with HERE+

Anthony did you solve your issues?

how did it go? did you manage to fix your issues? I’m having trouble with the same thing

Sorry for the delay in responding. In short, no, I did not resolve this. However, I should have some time this week to re-investigate and see if I can find a solution.