Servers by jDrones

Pixhawk 2.1 can't connect to the computer


(Yusuf Satılmış) #1

Hi. I have using Pixhawk 2.1 for almost 6 months and It was working properly. I have tried to connect storm32 gimbal controller card with telemetry 2 port today. It was worked properly first and then I have calıbrate the parameter “MNT_MODE;_IN” and I have selected the AUTO and then I have tried to reboot Pixhawk 2.1 and then It didn’t connect to computer when I tried. What I must to do? I think If I can reset to Pixhawk, It can be fixed but I couldn’t find how I reset the device. S


(David ) #2

Good day, are you able to connect with usb cable?


(Yusuf Satılmış) #3

No, we can’t connect. Also not detected by Windows “device manager” and no sounds from buzzer. Red light constant and yellow light blinking on the Pixhawk Cube.


(David ) #4

Try reinstall MP and just in case try download qgroundcontrol…


(Yusuf Satılmış) #5

I tried reinstalling mp and qground on different computers. I have tried to connect with different USB cable and with using RFD900X


(David ) #6

Try to disconnect the telemetry module… just check also the logs file of the boot on your sd card.


(Yusuf Satılmış) #7

At the moment nothing is connected. I’m just connecting the USB cable, but the PC doesn’t detect it. I could not find an error in log files. everything seems fine.


(David ) #8

when you power the fc, do you have any led light active or no?


(Nik ) #9

this seems to be a pretty widespread issue with the 2.1 cube, I have had this happen to two of mine now as well where they just completely stop responding and cannot connect via USB or Telem, on MP or QGC. the last time I had it happen, I was testing a motor on my quad when my laptop died, so I rebooted and the Cube just would not ever connect again! Even though the orange LED light comes on when its plugged into the USB cable, It’s very frustrating to have that happen.


(Yusuf Satılmış) #10

Red light constant and yellow light blinking on the Pixhawk


(David ) #11

Just try to power the fc while pressing the safety switch… aside this you can try to refresh the bootloader with a jtag