Servers by jDrones

Pixhawk 1 with HERE gps: problems

hi guys, i tried to put HERE gps on my 3dr pixhawk 1 but i can’t arm the board! i have 2 errors:

  1. GPS 1: u-blox SBAS settings configuration 0x1000
  2. PreArm: GPS 1 failing configuration checks

I used Arducopter 3.4.6 on my tarot beeper with 6s battery, power module mauch with 5.30v bec.

I have a good numbers of sat <10, and Hdop always under 1,5

if I turned off GPS_AUTO_CONFIG i can arm the drone, or if i disable geofence but i can’t arm in loiter mode.

any suggestion?

Thanks in advance

Hi Marco,

Those messages means ArduPilot isn’t being able to configure the SBAS option in your GPS. This sounds quite strange in a Here GPS, do you have all your cables connected?

What is your GPS_SBAS_MODE parameter value?

ARMING_CHECK = 0 here。

@xiaolang052 That’s a recipe for disaster. The arming checks exist for a reason, when there is a problem you should try to fix it, not ignore it.

on GPS_SBAS_MODE i have " NoChange"

I’m trying to think why it would be complaining about SBAS if you have it set to “No Change”, but I’m empty. I’ve looked at code and it should be working.

@WickedShell do you have any ideas here?

SBAS is not usable if using RTCM corrections. Is this a Here or a HERE+? Assuming it’s the latter setting GPS_SBAS_MODE to 0 will disable usage of the SBAS. (2 means don’t care, and you will also have it disabled in that case).

i tried with HERE+ and with normal here but i have the same error…

@pcmarko Have you tried changing the GPS_SBAS_MODE value (and rebooting after it)?

@OXINARF I’m thinking it might be worth trying to fingerprint a M8P as such (IE hit it with a poll for an M8P only message once or twice) and if it responds as such just always treat SBAS as an ignore option silently behind the scenes…) It would help address a lot of this type of problem.

@WickedShell Well, the default is 2 (No Change), so if it was changed the user should know what he is doing. What I’m failing to understand in this specific case is that the user said he had the parameter set to 2, which should clear the unconfigured flag for SBAS - but apparently it’s not.

Copter 3.4 will always attempt to request the GPS SBAS mode, regardless of if the parameter is set to ignore it. Master (and AC3.5) corrected this bug, but it never made it into the Copter 3.4 release cycle. Sorry about that, you will be fine on the Copter 3.5 branch with a Here+. A Here unit though shouldn’t be encountering any problems with the 3.4

I will try and get time in the next couple of days to test with one, but I’m a bit strapped for time at the moment so will have to defer that for a bit.

Servers by jDrones