Pixhawk 1 Solid Blue Light

I looked up the meaning of the various LEDs, but can’t find out what a steady blue I/O ACT means (the bottom of the three leds in the uppper left corner). Normally it blinks at 2 hz. Mine is a steady blue, which I think indicates a malfunction.

Anyone know what a steady blue LED means?

You need to be a little more specific. The Pixhawk design was used by many manufacturers and many used different colored LED’s than the first versions. What exact version of Pixhawk are you inquiring about.


Thanks for the reply. Its a 3dr Pixhawk. Not sure what other information I can provide to differentiate versions.

Thank you,


Does this help?


Thanks for the link. I’ve read through that a few times previously, but cant find anything about a steady blue LED, Its supposed to blink at 2 hz, but mine is solid blue.


How about this?

Blue - Heartbeat LED

2Hz Blink - Heartbeat Loop Running
Solid - Uploading new firmware for IO (red LED should be solid or blinking unevenly)


Thanks for following up. I did see that but prevoiusly ignored it because I wasn’t uploading firmware. However, I did try uploading copter ( I had plane loaded) and that seems to have fixed the problem,

Now I have another problem. I can connect to the pixhawk loaded with copter but not when plane is loaded. The middle I/O LED is solid amber with plane loaded and off when copter is loaded. Not sure why?

Thanks again for you assistance.


Can you describe what procedure you use for loading the (correctly-working) Copter and the (not-working) Plane firmware?

Are you able to try uploading a different version of Plane, or uploading it in a different manner? (e.g. use QGC rather than Mission Planner, or compile-from-source, or something)

Same procedure for both versions of firmware using mission planner. I even tried loading rover - it worked, no problem .

I upgraded to the lastest version of plane. I loaded the previous version of plane and still couldn’t connect with plane loaded. I can connect with copter and rover loaded, but not plane. Wierd!

Very strange.

If I had your problem, I’d try using QGroundControl, or learn to compile-and-upload from the source, see if the results are any different. It might (or might not) be worth you learning to use these methods to see what you can learn…

Try going back versions of plane until you find one that works or you give up and call it a bad brd.