Pixhawk 1 no voltage at Telem ports

Hi all,

I’ve built several quadcopters from scratch using APM 2.6. This is my first Pixhawk build.

I have a Pixhawk 1 and I’m trying to connect a set of 3DR telemetry radios. I know the radios work because I’ve tested them in another copter. I also tested the DF13 cable and its good. When I plug the radio into Telem 1 or 2, it doesn’t light up. I checked the volts on pins 1 and 6 of Telem 1 and 2 and I’m only getting 0.24v. Shouldn’t I be getting 5v on both ports?

When I power the Pixhawk it makes the normal startup sound, then there is the flashing yellow light because I haven’t connected the external GPS/compass yet. It has Arducopter 3.4.5 loaded.

Any ideas? What other tests can I perform? Am I missing something?


Sounds like something got fried. When I plug my Pixhawk 1 in via USB the 3dr radio and x8r receiver both light up.


Thanks Mike. The thing is, my X8R gets powered by the Pixhawk and works just fine.

Servo power (what your receiver is on) is a different circuit to Pixhawk power. If you have the radio plugged in and you plug in the USB cable does the light on the Radio come on? If not try Telem2 and see what happens.

Thanks, Grant.

If I just plug in the USB and no main battery, the X8R lights up but there is no voltage at Telem 1 or 2

Also, I just unplugged the X8R from RC IN and checked the volts at RC IN and its 4.5v (USB connected, no main battery)

With a main battery connected, RC IN is 5.07v, still nothing (0.05v) at Telem 1

Again - if you have the radio plugged in and you plug in the USB cable does the light on the Radio come on?

Thanks, Grant.

No, the light on the Telemetry Radio does not come on at any point.

The Radio works fine on my other ships


Ah ok - thanks for that info. It doesn’t look good then for the telem1 port. Have you tried the telem2 port? Its powered differently to telem1 so you might get lucky. Note that the Telem2 port doesn’t provide as much power as the Telem1 port so don’t put more then a standard 100mW transmitter on it.


I don’t know of a way you could of accidentally disabled the power to the telem1 port via parameters or anything like that. It “might” be worth putting a different vehicle type firmware onto the pixhawk (backup your parameters before you do this) which is a crude way of completely erasing the eeprom on the pixhawk and then putting back your correct vehicle firmware and before you reload your parameters test if the radio is getting power. Again its unlikely this will help but it won’t hurt either.

Sorry - one last thing - its a 6pin to 6pin straight through cable right - your not trying to use a 5pin APM cable by accident?

Thanks, Grant.

Thanks for the reply. I tried Telem 2 as well. Nothing. I was using a 6pin to 6pin.

I’m sending it back.

Yeah - seems dead. Sorry. Are you going to get a replacement or a refund? If its a refund the Pixhawk 2.1’s should be available again in the next week or so. Heads up the PH2.1 uses different (much better) connectors :slight_smile: so your exisiting parts might need a new cable soldered up.

Thanks, Grant.