Pixhawk 1 GPS Modes fail on 2nd battery

I have a problem with one of my pixhawks…

I buit 2 drones, both with very similar hardware
Pixhawk (HK clone)

One is a quad, one a hex.
The Quad so far has worked just fine.

On the hex, it is another story.
The first battery works fine. It acquires GPS signal, I take off, flys good, GPS modes (drift, hold, RTL etc.) work fine.

I land, take off the battery, attach a new battery and take off again. It is without power anywhere between 20s or 5min, doesnt matter.

Now I take off in stabilize, everything works fine. As soon as I switch to a GPS mode (drift, hold RTL etc) it “leans” to the side and drifts off in a random direction. In RTL it fails and switches back to stabilize, in hold as well sometimes.

Anyone have an idea?


Could be the GPS receiver failing have you tried swapping it with the one on the hex

In mission planner does it show any SATs, if yes how many and how does that compare to the hex connected to mission planner

Hi Paul,

Yes it showed 12sats via telemitry link - HDOP was also ok, I have not overridden any checks, when it has too few sats or bad hdop it does not let me switch into GPS modes at all.

I cannot swap the GPS because of different mounting.

What irritates me is, that it works flawlessly on the first battery. no drift in any direction on hold, “drift” mode flys amazing, RTL (thank god only for fun, no “oh shit” moments) works as intended. Only when I unplug the battery connection does it make problems.