Pixhawk 1 and Tarot Gimbal Setup Arrggghhhh

Going nuts trying to get a new Tarot Gimbal to work through the Pixhawk. Equipment

Pixhawk 1 Standard
Tarot T3DV Metals 3 Axis Gimbal
Taranis QX7S
X8R Receiver

I have checked to see the gimbal works by switching it the gimbal to SBUS mode using the dodgy Tarot software and can make the gimbal tilt and pan using the pots on the X7S (set to Chan 11 and 12). So the gimbal works.

I reset the Gimbal to
Pan Follow
Tilt to Ch11
Pan to Ch12 (Also tried 9 and 10)
Latest Ardcucopter NuttX 3.6.7

Then as per http://ardupilot.org/copter/docs/common-tarot-gimbal.html i have set TILT to Ch9 with input channel = RC11 and PAN to Ch10 with input channel = RC12. Set Gimbal type to Servo. Then plug Tilt and Pan leads into Aux 1 and Aux 2 (minus the red wire) on the PIxhawk

Nothing. Cannot control gimbal. It stabilises and looks forward ok but will not move when using pots on transmitter. FPV mode.

Anyone got any ideas?

log_2_2019-4-6-17-59-56.bin (720 KB)

Note tha I have disabled the safety switch with BRD_SAFETYENABLE

can you post up the parameters are using

Remember when you are testing, if you are using the safety switch, you get no output on the aux ports until the safety swtich is enabled.
In conventional PWM the gimbal there is no mapping of the RC ports. Selecting the ports is only valid for s.bus input. Make sure your aux ports are set to analog not digital.

I have posted a log file of a bumpy test flight

Thanks. I have disabled the switch using BRD_SAFETYENABLE. As for the mapping I was not sure if that made a difference. I did not think it did for non sbus but did it anyway. I have set two AUX ports to Analog bu setting the parameter BRD_PWM_Count to 2. What do yo think ?

you have MNT_RC_IN_TILT 11, so RC 11 should control tilt. MNT_RC_IN_PAN is 12. You have tilt ouput on servo 9, this is aux 1, however Pan is on servo 12, this is aux 4. If you have it plugged in to aux 2 you need SERVO12_FUNCTION = 0 and SERVO10_FUNCTION = 6.

In your test flight you don’t have and change on RC 11 or RC 12 so you wouldn’t expect any gimble movement. RC out 9 (aux 1) and RC out 12 (aux 4) are both outputing constant pwm in the test.

So from the log it looks like its working fine.

Thanks for the anaysis I will try your corrections. Appreciate the input. Will have to wait till next weekend. Thanks again. RM