Pixhawk 1 (2.4.6) B/E Light Solid

Hi all, I have Banggood 2.4.6 Pixhawk that was working on the bench except for pre-arm check logging error with plane 3.9.2. I read somewhere that there is an issue with nuttx vs chbios operating systems and I attempted to flash Arduplane V1.px4 onto it, which I thought would at least demonstrate whether or not it was the os causing the issue, now I can’t connect to the autopilot with radio or USB and B/E light is solid after flashing for a few moments, the multicolor LED won’t light up at all and no tones come from the buzzer. It does allow me to flash new firmware (I’ve tried flashing rover then going back to plane, plane itself, all multiple times) and is clearly connected because it asks me to unplug then plug the USB cable back in during the firmware update as well as giving me status updates (erasing board, flashing firmware, etc…) I’ve verified the sd card is seated, formatted it to FAT32 at least twice, it is blank - no log files at all. It was working 100%, minus the logging, connecting with both radio and USB, had it all set up for my airframe, I’ve tried booting with the safety switch held down, the reset button next to the USB port, reloaded drivers and APM Planner. Any advice? I know this is what you get for buying a knockoff Pixhawk, but gotta start somewhere…

-Mac osx 10.13.6
-Pixhawk 2.4.6
-APM Planner 2.0

I used the custom option in the firmware upload screen of APM planner to flash px4fmu-v2_default.px4 and that has brought it back to life, then I used the same method to flash 3.9.2 that I found at http://firmware.ardupilot.org/Plane/stable/Pixhawk1/. It appears to be 100% now, no longer getting the logging error at pre arm check, I’m assuming this fw is based on nuttx. I think initially the fw I uploaded was for the pix 2 or later and this was the root of my issue, when the status window in APM Planner tells me its checking the boards serial number when flashing the firmware my assumption was it would be the correct version but maybe this isn’t so?

I turned on the terminal to see the raw data coming out, it’s mostly nonsense, except for the first couple of lines, is there a setting I’m missing?