Pixhawk 1/2.1 imu data comparision on 200 lb helicopter


I gathered some data today with two pixhawks (1 and 2.1) - and was amazed at how much better the 2.1 data is. I tried several different mounts for both and as I read on the forums here that pretty stiff mounts tend to work best that is what I found too.

Both autopilots are mounted on a gas helicopter here at Georgia Tech - in past we have used more high end sensors and used internal autopilot software. I wanted to gather data to see how the mems sensors would work on this size vehicle and potentially fly with it. Plan to try flying the 2.1. From brief look at helicopter code - I need to add manual mode similar to ArduPlane - as safety pilot wants the ability to have direct control capability - so stab/acro won’t suffice. I’ll update progress as I move forward.

1 Like

Are you flying it on a Rmax with a flybar? Or is this a FBL heli?

You can have a manual mode with Acro by setting H_FLYBAR_MODE to 1. It is direct pass-thru of control. That is normally used with a flybar, of course. But also with FBL to use a downstream FBL unit with the Pixhawk.

I set up the flight mode switch to automatically switch in my own custom rate and expo curves in the transmitter when in Acro flight mode with a FBL heli and H_FLYBAR_MODE set to 1. It doesn’t affect any of the other flight modes.

You will have to also set the roll and pitch rate VFF’s to at least .25 and reduce the ATC_ACCEL’s to a level that will provide smooth response.

It is not a recommended or supported configuration. But it works.


It is a flybar setup - thank you for info. If the goal is to eventually get to ‘Auto’ mode would it make sense for me to add a manual mode as the Loiter uses lower-level controllers- which will have to be tuned (not in H_FLYBAR_MODE?) - I’ll look at the copter code and see how this mode is used.

The safety-pilot at all times wants the ability to kick-out of anything the pixhawk is doing. So even while tuning acro/stabilize/alt-hold before loiter the pilot will want manual avail.

thanks again!

If it is a flybar, then you are using flybar mode turned on. In Acro with flybar you have full manual control. The EKF can blow completely up, the Pixhawk can lose its attitude solution, and it doesn’t affect it at all.

It is my go-to “bailout mode” when I’m testing anything in the software that might break.

Awesome! Less work for me :slight_smile:

Gonna attempt tmrw to connect and fly in ‘acro’

Thank you for info

Just make sure you have the VFF’s set correctly. Minimum .25 for flybar and the roll and pitch rate PID’s are all set to zero. You can set the rate I-gain to maybe around .12 and it will make it fly smoother in Auto flight.

But when you switch to Acro test your stick input vs servo output to make sure you are getting full servo travel, and at adequate rate for a flybar. The VFF (or feedforward) is the setting that affects that. Setting the VFF higher will increase the rate for both the pilot and autopilot. Which is not a problem with a flybar because the flybar provides the damping anyway. Depending on how fast the servos are, I’ve set some of them up to .38 VFF.

If you didn’t have a Pixhawk and were flying the heli just with the RC radio, the VFF does the same thing as the rate setting in your radio.

1 Like