Pixhack v5 traditional heli

Dear All,

I have uploaded beta version from mission planner 3.60.rc8 version which is coming by default when I hit beta firmware.

I managed to upload but all heli parameters are not loaded. Which version do we use to fly with cuav v5 board ?


You need to set parameters based on your copter design, power, and personal preferences. This isn’t something generic.

You need to install the heli build. It is a different build than Copter.

Do i need to compile that version? As i can not edit beta versions that i know.

I have created a compile setup on linux yet it will be good to know the compilation command if anyone knows for heli.

No, you do not need to compile it. I don’t know the status of Mission Planner right now as far as loading firmware for the V5. It is fully supported in the daily build of QGroundControl though for the beta 3.6. Just select ChibiOS for heli and QGC will automatically put in the right firmware. Plus the heli setup page in QGroundControl works. It does not work in Mission Planner.

For tuning for Copter3.6 heli we have param files you can simply load with QGroundControl - will give you a stable machine “out of the box” and only have to adjust the VFF’s for response to your preference and size of helicopter, and maybe adjust P and D gain for the tail, depending on how fast your tail servo is.


If you have a build environment set up on linux it’s very simple. Check out the Copter-3.6 branch, then from the root of the repo (ardupilot directory) do;
git submodule update --recursive (ensures you have the right submodules)
./waf configure --board CUAVv5
./waf heli --upload (make sure your controller is connected via USB)

The last command will build the binary and flash your controller.

Well for some reason CUAVv5 is not working for me. When I plugged the FMU to QGC the found device is PX4 FMU V5. I cannot find this specific board at board list honestly.

When I choose CUAVv5 and compile and upload during upload ChibiOS crt1.c is failing with no rule make target lines.

I tried to google those but didn’t get anywhere. Gog i wish things are easier for me not the harder way all the time.

I have done the steps as Chris indicated by the way. Is there a hex file that I can simply download and and upload that thru QGC.

QGC seems not finding the firmware either as I select the Advanced tab under arducopter and there are only stable, beta, development and custom options that I can choose. Drop down menu is coming empty. When I select the beta it gives error saying no firmware found for the board.

Does anyone has gone thru these stages before? Am I forgeting something to sycn ?


I can successfully load the PX4 flight stack to this unit but the heli setup parameters are totally different than arducopter ones.

So I am not sure I will prefer PX4 stick to fly the heli and I cannot get arducopter on this unit either.

What to do ?

You need the QGroundControl daily build from here


The board is a PX4 FMUv5, which is the official name for it as far as firmware is concerned.

Dear Chris,

That just worked out well. Thanks for the help.

Will post the test flights soon.


doesn’t work for me:

I choose Advanced-BETA + ChibiOS: Heli - Arducopter V3.6.0-rc10.

Upgrade is succesfull but no connection is possible afterwards.

this is what I get from today’s daily build Qgroundcontrol Console when updating firmware (2018-09-25 12:27:28 -0700):

QGroundControl can upgrade the firmware on Pixhawk devices, SiK Radios and PX4 Flow Smart Cameras.

Plug in your device via USB to start firmware upgrade.

Found device: PX4 FMU V5

Connected to bootloader:

Version: 5

Board ID: 50

Flash size: 2064384

Downloading firmware...

From: http://firmware.ardupilot.org/Copter/beta/fmuv5-heli/arducopter-heli.apj

Download complete


Firmware file missing parameter_xml_size key

Firmware file missing airframe_xml_size key

Successfully decompressed image

Erasing previous program...

Erase complete

Programming new version...

Program complete

Verifying program...

Verify complete

Upgrade complete


If you are on Windows it won’t connect automatically after loading the firmware due to Windows’ com port thing. It only connects automatically on linux. So go to the “Q” and click on Comm Links and setup a serial connection. It should list the com ports Windows has and it will be on one of them. Select that and make the link, then click connect and it will go.

I found on Linux and Android it connects all by itself. On Windows it don’t because of those so-called “com ports” that Windows uses.

1 Like

Ok. Understood.
succesfully connected!!!