Pixfalcon will not download log files over radio

Currently setting up a pixfalcon in a Hiro frame with AC3.4_RC1

Any attempt to download the logs via MavLink causes a time out at around 1000 bytes.

Have tried Mac and PC, APM Planner, Mission Planner, QGroundControl, all give exactly the same result.

Can download via USB but the connection is buried in the frame and the I2C USB connection does not power up the Pixfalcon.

Anyone have any suggestions?

PS: I am using 3DR radios both ends as I purchased heaps when 3DR were clearing house.

This may or may not be of any value to you, but I am able to download dataflash logs from my PixFalcon by radio using Dragonlink Advanced v3 talking Bluetooth to Mission Planner. This was pioneered by RCG user Noircogi on the DLAv3 thread on RCG. I am guessing you are using 3DR radios or something other than DLA. So maybe this is of no value to your situation. Though the ability to download wireless is tedious for me, and I have good USB and microSD card access on my PixFalcon, so I usually pop the memory card to download logs. Good luck.


Download of logs over radio is not supported. Way back in the day that kind of worked but was abandon because it was not very reliable.

USB is the only way it works.


… or unplug your SD card from your pixhawk and stick it into a SD-card reader in your puter. :slight_smile:

Unfortunately the Hiro frame is a sealed and fully enclosing frame.
Getting a USB cable into the PixFalcon is akin to key hole surgery.

Seems a backward step to not have access to logs over a UART connection?