Pix hawk initial setup failes

I cannot connect px4 2.4.8 to my pc i tried so many things versions of mission planner it didnt worked tried some drivers too it also not worked even my pc cannot detect the px4 or drivers but high beep sound and yellow light blinking please help me

Well, dificult to find out with these data. We need more infirmation. Operating system, baudrate to connect, port…

Remember that Mission Planner is not directly related to any of the connection problems. It simply connects to a serial port provided by Windows. So you need to get Windows to install the drivers properly. When you install Mission Planner it installs drivers for the various flight controllers at the same time. Make sure your anti-virus, defender etc is not blocking the install. When you start Mission Planner and drop down the list of COM ports in the upper right of the Mission Planner main screen, note all the com ports available. Then unplug the Pixhawk, if none of the com ports disappear then Windows does not see the Pixhawk. If one of the com ports does disappear that is the com port that the Pixhawk has been assigned by Windows.

If your laptop does not supply enough power to it’s USB ports it is possible for the Pixhawk not to boot. Try using an external powered USB hub to solve that problem.

1 Like

Javier & Mike,
I’ve been searching on the internet for a solution to this problem since I am having identical issues described by Harsha Teja. I am very frustrated with attempts at setting up PixFalcon Micro PX4 Autopilot flight controller. This is even my second flight controller as the first one bought was from a foreign website and seemed to be a knockoff. I once believed the reason it might not be working is because it was not a “genuine” brand. After receiving the second “original micro pix4 falcon” from Hobby King online, and plugging it all in, Mission Control software cannot recognize it either. They both light up, makes noise, and while both modules appear to be working neither will connect to Mission Planner! It is not only Mission Planner, I’ve tried Bettaflight configurator, APM planner and several others on a Windows 10 PC.
I’m using a MacBook Pro running OSX High Sierra 10.13, and also tried hooking it (with the same results) to my Windows 10 desktop PC. I also have been looking at the online manual downloaded from the Pixhawk website and various other internet tutorials, but still found no solution. My computers will not recognize the comports (USB port) when I plug in the flight controllers. I’ve been working, on and off, with this quadcopter build for a long time now. I seem to be running out of patience on this. :confused:
Mike, In reading your comment above I understand what it is you are saying. I’m able to see COMM ports 3, and 4 in a dropdown box, but there are no “COMM’s” that appear or disappear when plugging or even unplugging my flight controllers in. Even In Window 10 when opening device manager, the number of COMM ports remain the same reguardless if a flight controller is plugged in or not! Mike, I noticed in your comment above you state a “need to get Windows to install the drivers properly”. I’ve noticed when installing Mission Planner that a dialog box comes up verifying the drivers. In an attempt at troubleshooting, I’ve also tried different baud rates with the same results. ARRRRRRRGhhhh…
I would greatly appreciate any help offered!


OK first don’t give up on your flight controllers because you have never even hooked them up.

As I mentioned before you have no drivers installed for the fiight controllers. Before getting to that did you get a buzzer of some kind with your fc? The beep tones are helpful to know if the fc is booting correctly or not.
Ok I would start from scratch and uninstall Mission Planner, APM Planner and the betaflight configurator won’t do anything for you it is not for Pixhawk.

Second the question is do you have anti-virus, Microsoft defender or some other Windows Protection software that is interfering with installing the drivers?

Turn off anything that might impede getting Mission Planner installed. Unplug from the internet if you are concerned with your defences being down while you test this. Try reinstalling Mission Planner and use the latest version.

Do you have some other USB device you can plug-in to see if the Windows is assigning it a com port correctly? You will be able to see any new additional USB devices, properly installed, inside Mission Planner as a new com port.

1 Like

issue solved now iam able to connect now and installed the firmware but yellow lights are comming from tthe boards that show system error please help me on that thanks for your help you made may

dear shannonn goodwin

  1. try this thing open your windows pc and unistall every thing mission planner drivers everything
  2. get 3 to 4 data cables of different brands use original samsung data cable if avaliable
  3. go to http://www.ftdichip.com/Drivers/VCP.htm go and install executable version which in comments box of windows
  4. install latest mission planner and allow all permissions if prompted and install drivers from it
  5. restart your pc and try connecting with different cables it will work mostly

all the best

The lights of all these boards are different so there is no way to figure what it is doing. Can you connect to mission planner?

Yes i can connect still that yellow light iam unable to. Bind my fs th9x too csn u figure out a way