Pitch oscillates in QLOITER mode

We’re developing a quadplane considering long range and heavy payload. So the quadplane itself is very large and weighs about 12 kgs.

Before switching to autonomous mission, we wanted to ensure that everything works fine and tried it out in QLOITER mode. However, in QLOITER it gives oscillations in pitch axis and is very unstable.

It does not show any error messages and all the sensors seem to be working fine. We also tried it out in QHOVER mode and surprisingly it has no issues. It also works fine in QSTABILIZE mode. How can we fix this?

To be extra sure, we’ve also enabled Q_GUIDED parameter.

Firmware Used: Arduplane 4.0.1

In the bin log, we can see that the des_pitch is itself oscillating which probably caused the pitch to oscillate as well. You can see the video below.


Bin log:

Telemetry log:

Can you send a file with your Parameters?

Here a few initial thoughts:

  • Have you followed the Quadplane VTOL Tuning Process described in the Wiki ?

  • Have you checked the CG?

  • Is your Flight Controller mounted in the CG?