Pitch is reversed in mission planner

Hi,

After calibrating the arducopter installed on my quad copter, I was checking the movements on the mission planner and the pitch is reversed when check in the HUD of the mission planner. I have calibrated it a few times now its still the same, I am not sure what I am doing wrong. Is there a way to reverse the direction of the pitch ?

Thanks,

What FC are you using? What version of MP and AC?

it’s the same on mine… the graphical display shows the pitch reversed…
Strangely however, the actual quadcopter works correctly when flown!

So is the green part of the hud display going up or down when you tilt the nose of the quad up? It should go down if all is working well.

You can reverse pitch by changing RC2_REV to -1 (if I recall correctly - copter.ardupilot.com/wiki/arduco … se_RC2_REV) but you should be sure to check first if it’s not just your radio that needs pitch reversed?

it goes up. I will try the RC2_REV parameter. Thanks

Actually its not the radio that needs to be reversed. Its the accelerometer.

Don’t know if you’ve solved this yet. But take your mouse place it over your HUD. Right click on HUD. In the drop down menu, left click on Russian HUD. This should solve the problem. I don’t know if it will affect flight characteristics, but your HUD will move correctly. If anything seems funny Click on Russian HUD again to reverse it. Hope this help someone.

1 Like