Pi zero copter 3.5 udp ground control station not working

I have compiled copter 3.5 over and over and after 2 hour plus compilations I run into the same issue regardless of the network I am on. I see the connection to the ground control station initially over wifi using udp but then it disconnects. I see that arducopter is still running on the pi zero but it hasnt been configured for me to test anything further. Has anybody else had this issue. it works with copter 3.4.6

Hello Alex,
What is your launch command for arducopter ?
Do you ping OK the gcs from the RPI ?
Can you ssh to the RPI ?
Have you looked at dmesg to check there is nothing ‘‘funky’’ ?
Does tail -f /var/log/syslog show any errors ?

command used to launch is arducopter-quad -C udp: &
I am sshed into the pi zero while performing this from the laptop that is running the pi zero.
Didn’t see any issues in dmesg when i glanced over things. I am trying to tune the same quadcopter with arducopter 3.4.6 as that is the last version I was able to have run stably on the pi zero.
I deleted my build out of frustration and crosscompiling seems to be a nogo not sure if there is an issue in the scripts to crosscompile but i haven’t successfully been able to cross compile and run arducopter. Could only assume it is compiling for a pi2/3 didnt try the binary on one of those yet.

Humm… I will build a new one from master and report

For cross-compile, have you
sudo apt-get install -y pkg-config-arm-linux-gnueabihf
Look here: http://docs.erlerobotics.com/brains/discontinued/erle-brain-2/sofware/apm/install_binaries#build-apm-using-waf-cross-compil-
and here

patrick, are you saying that the scripts that resides in tools for installing the prerequisites for ubuntu is incorrect. I will attempt to install said package but it still doesn’t fix the issue with the udp connection dropping quickly. I now have 3.4.6 working but would like the latest 3.5.7 as it is supposed to have arming and disarming by switch. when coming in for a landing this thing tends to bounce around making it even harder to disarm. This is probably due to the underslung battery