PH2.1 final release and battery monitor issues

I’m having issues with the Battery monitor recording incorrect AMPs.
I have tried 2 DIffernt Battery Monitors and 2 differnt cables that come with the PH2.
I select the Cube power supply.
Celebrate my voltage, then draw 10amps and enter the measured Amps
Power down. then sitting there the Apms jump around 0.3 to 10amps while nothing is running. My what meter is measuring .3apms very consistently.
When flying the apms jump around from 1amp to 56amps. I know my set up well and from expreace, I’m pulling between 4 and 7amps
This causes the PH to think the battery is flat in about 5min.
Is there a new calibration procedure? Is there any known issues here? I have not had this issue before.

Firmware 3.7.1

Just trying to determine the cause before I talk to RFDeign about this PH2.1 posably being faulty.

SOLVED = I use these regulators in quite allot of my setups.

I put them inside the shell of a camera battery and use them to power the cameras of the flight battery.

Something about using 2 of them in parallel to run 2 cameras was causing all that noise.

I’ll have to make up a special battery harness and use one to power 2 fake battles.