Passthrough telemetry over CRSF (crossfire)

It will not work with RCin. As the name suggests, the port only receives data. But the Yaapu script needs a telemetry feedback.

Why can’t you use UART?

1 Like

Because there is no way to connect a single UART to both internal flight controllers.

Suppose that wasn’t considered. As you say:
RCIN

Hello @yaapu , I am looking for a way to get into the Yaapu config settings on the Radiomaster Pocket (bw 128x64 display) in order to enable the CRSF passthrough. In the tools menu, there is no “Yaapu Config”. I could find config lua scripts only for the c320x480 and c480x272 folder structures (not copied, as I am using the files from the bw128x64 folder).
On the Radiomaster Zorro and Boxer, you can get into the configuration by pressing buttons in the sequence TELE → RTN → TELE but this does’nt work on the Radiomaster Pocket.

Is there any workaround by manually editing a config file (where located? how to set the CRSF passthrough to enabled?)

Very slow telemetry update - CRSF - Ethos.
I have done a few component updates over the last few weeks and now have a very slow update rate. The horizon for example, takes about 10 seconds to show a movement. I usually try to fix the CRSF link rate at 50hz but from memory the telemetry was faster before. I can see the ‘sensors’ getting polled at a infrequent rate. Is my memory correct, and it was faster before? Is there anything I could change to improve?
I haven’t tried the 4hz (forced telemetry) rate yet. Would that be very slow?
Thanks.

@yaapu

Hi Alex,

I have a FC with Arduplane 4.4.4 and ELRS 3.3.2.

With EdgeTX 2.9.4 I get 30 telemetry entries on a RM Boxer with b/w Yaapu script. But on a RM TX16S with color Yaapu script only 23 …

The configuration of both Yaapu scripts is the same (enable CRSF support = Yes).

Why are fewer telemetry entries displayed on the RM TX16S?

Hello everyone,

i see there have been alot of discussions here, i have the following setup

  • Radiomaster TX16S running OpenTX 2.3.15 software + radiomaster ranger running V3.3.0 ce_lbt

  • Yaapu telemetry widget 2.0.x dev ( also Crossfire is enabled in the settings)

  • FC is a Pixhawk 2.4.8 running arduplane v4.5.1

  • Receiver - ER8G running V3.3.2 elrs

On the TX side packet rate 250hz, Telem ratio 1:128

On the RX side init rate is 250hz

The elrs receiver is conected to the pixhack via the side tx/rx pins, which go to the pixhawk in the “telem2” port ( SERIAL2 in missionplaner)

In mission planner i have setup these parameters for the pixhawk

SERIAL2_BAUD = 57 ( as i understood the baud is handled automaticaly by the sw)
SERIAL2_PROTOCOL = 23
RSSI_TYPE = 3
RC_OPTIONS = 32 + 256

I can see all the rc channels working, except the mavlink telemetry…

I know there are alot of discussions in background about this, but i just wanna know, if i am doing something wrong, or should i consider a second rf link dedicated for telemetry only.

Thank you

Hi, your Telem ratio is too high, it means you send a telemetry packet every 128 RC packets which is 250/128 = 2 packets per second, way too low, you need at least 25Hz, so try 1:8 or even better 1:4

Hello Alex,

unfortunatly this also doesn’t seem to work, i tryied with diferent ratios, and it stil does not display any telemetry data.

But for curiosity, i’ve connected a logic analyzer on the tx/rx lines to see what activity i have.

I can confirm that elrs module is sending date to the pixhawk, however the px does not send anything to the elrs’s receive pin.

And notice this behaviour when i cange the serial_protocol from 2(mavlink 2) to 23, which somehow makes sense.

But why is this? If crsf is a full duplex protocol, why i dont see nothing sent back to the receiver?

I will try to connect the receiver rx pin to another serial port from pixhawk setup as a mavlink telemetry

Ok, it was a bit strange to transmit data from another usart periph… this offcourse did not work.

But i still wonder why pixhawk doesn’t send anything to the crsf module?

Is this feature available for pixhawk-1M firmware? I already spent the entire day trying to figure whats causing this.

Later eddit: i have uploaded the firmware by chosing “fmuv3”, and now the telemetry works.

But i am a bit confused about the software structure when chosing to upgrade the ardupilot trough mission planer

I cannot figure out how to enable crsf on the radiomaster zorro. Does anyone have any idea? I have installed the dev branch and I am able to discover 24 sensors when I hit discover but I cannot get it to show up on the telemetry page running 2.0.0 dev. I know it is because I have not enabled CRSF but I cannot figure out how to do so.

Installation for both Taranis and Horus class radios

  • follow the standard setup instructions for your radio
  • for Taranis radios enter the script config menu (long press [MENU]) and enable CRSF support
  • for Horus radios enter the Widget config menu (long press [SYS] → Tools → Yaapu Config) and enable CRSF support
  • enable passthrough over CRSF on ArduPilot by setting RC_OPTIONS = [current value] + 256

I have two pixhawk 2.4.8, one is 2nd generation and another is 3rd generation. The 3rd generation pixhawk was installed fmuv3 copter firmware. Yaapu (the latest version) runs perfect and shows telemetry. Another one was installed with fmuv2 and shows no telemetry except the receiver’s telemetry like 1RSS, Rqty, etc. It seems the passthrough not working. The transmitter Jumper T16 with ExpressLRS module v3.4.0 runs the latest version of EdgeTx. I wonder why the passthrough only works on fmuv3? Thanks

Update to fmuv3 on both regardless of generation.

I updated it to fmuv3 and it works. Thanks. I wonder why the firmware makes a difference. If yaapu script is firmware dependent, I need to know which FC will work with it as I want to buy a new one.

Before using ELRS, I used Frsky receivers and the yaapu script worked perfect no matter what Ardupilot firmware I installed.

I have it working on my zorro it took a while to find the menu, its just about pressing the right buttons, can’t remember off the top of my head but i will check it out again and post when i find it

please do share when you figure it out I have seen a few combos but have not found out how to get into the menu to set CRSF