Passthrough telemetry over CRSF (crossfire)

Hi,
do not use my firmware, use the official one, for instance for plane on a matekF405-Wing download the apj from https://firmware.ardupilot.org/Plane/latest/MatekF405-Wing/arduplane.apj

This is something I’d like to know more about, haven’t been able to crash it, if you get it to crash again, please do the following assuming you’re seeing “disabled” on the crashed widget screen

  • long press [tele]
  • press [page] and select the correct telemetry page
  • select “setup widget”
  • press wheel
  • select widget settings

finally paste here the message you get

thanks

yes i figured that out, i did download from ardupilot Latest folder, its this one you have posted, i just checked again everything is running fine and smoothly always in rfmd 2 mode, map moving without delay, and flight modes are announced and displayed correctly

…and so, what was it, I’m curious since it took so long :slight_smile:

there were 2 causes which i figured out with my limited knowledge.
1 - when i disabled arming by rudder and just use my throttle cut switch the telemetry was not coming the moment i reverted back to the default arming settings Yaapu started working again.
2 - this 2nd one was my fault as i had reset the board and wrote the recommended settings i forgot to write the flight mode channel in MP which was causing wrong announcements for flight modes and it was mostly announcing copter flight modes but after changing that everything is working great.
Only problem i have now is i dont like arming through the rudder stick and when i disable that Yaapu says no telemetry but thats not really a big but if there was a way around it would be great

for issue number 1 I can try to reproduce, can you attach your parameters?

i will reach home in an hour and post the Parameter file from MP

I was getting the “disabled” message, but only on the main flight screen. The messages and map screens were still there but not updating. I tried to do different resets (Flight, telemetry) but none had any effect. The only way I could get it to work again was a hard reset of the radio. Would there be a way to reset it if that was to happen while flying?

I’ll post any results if it crashes again.

here is the working param file.
to reproduce the issue just change your flight mode channel in MP to something wrong28-jan-2021.param (24.3 KB)

Just logging in to thank @yaapu for the great work. I had lost all hope to get telemetry working over crossfire.

I got this working fine on my boat. The refresh rate of data seem to fluctuate up to 5 seconds, but hey, can’t complain as it works for my purposes just fine!

My rig is :

  • Rover, version latest (2021-01-28). Pixhawk 2.4.8 (=fmuv3).
  • Radiomaster TX16S SE with Crossfire Micro v2
  • Crossfire Nano receiver on boat, using ports 1&2
  • Using serial port 2 (= telemetry 2)
  • (SiK Radio MAVLink telemetry in serial 1)

It took the usual configuration steps:
RC_OPTIONS += 256 (=288)
SERIAL2_PROTOCOL = 23
SERIAL2_BAUD = 57

Enable CRFS in Yaapu script settings in the radio.

It took pretty much effort to get this working. The main culprit was one bad wire. I have a cheap chinese version of Pixhawk, and the tx-wire of telemetry cable was connected badly, resulting no tx-connection. It took lot of hours to find this. The main lead was in the logs (messages), as it some point indicated not having connection to RX-device.

The second problem was with Lua-scripts. Somehow I had taken the stable variant of the scripts without the CRFS-support. No wonder, these did not work. This was found because basic CRFS telemetry was working and Rover indicated it was sending packets, so it had to be problem in the radio.

After these were solved, it was pretty smooth ride.

Once again, thanks for @yaapu and everyone who made this possible.

Hi, well this is not correct, should be smooth, a lagging refresh could happen if for some reason RF mode is NOT set to 2 or keeps switching between 1 and 2, another possible reason is you have the TBS agent connected to the usb port on the back of the TX and finally you might trigger this (but I wasn’t able to reproduce) if you have the wifi connected and the WiFI TBS agent is requesting parameters

1 Like

The Mission Planner messages log shows that its constantly switching between modes 1 and 2. Log on radio says mode 2. Any idea how to fix it?

1 Like

update crsf firmware to latest and keep tx and rx further apart while testing

1 Like

Can’t get yaapu working correctly.

Kakute F7 w/ Arduplane 4.1.0 beta downloaded today
Jumper T16 Pro OpenTX 2.3.9
yaapu 1.9.3 Beta downloaded today

Arudplane, Qplane VTOL setup
SERIAL1_BAUD=57
SERIAL1_PROTOCAL=23
RC_OPTIONS = 288

Tracer Rx v5.4
CRFS Tx and CRFS Rx set in Rx

yaapu config
crossfire = yes

RC controls work correctly! & first 9 sensors work, (but that’s just the crossfire stuff). No ardupilot telemetry is coming down, been working on this for +weeks. What am i doing wrong? thank you.

1 Like

Do you lack the ardupilot telemetry on the radio entirely (not appearing either in the yaapu script or the radio telemetry page), or do you see it in the radio telemetry page but it’s missing from the yaapu script? After each thing you’ve tried, have you rediscovered sensors?

1 Like

Don’t have telemetry in either. Discovery does not yield sensors.

BTW with mavlink Tx and Rx setup telemetry does work fine. But don’t work with CRFS setup, no ardupilot data.

1 Like

Hi Alex, one importend issue I have found.
If you are using a TBS Crossfire Micro RX V1 - CRSF only for RC Signals. No Telemetrie possible.
The TBS Corssfire Micro RX V2 could handle RC and Telemetrie for CRSF.
I have had this issue and getting crazy why some Micro RX was working and others not.
After a long search I found the notice in the german crossfire manual, page 15.
Cheers, Markus

1 Like

Dear all, is it possible to have WingFC 10-DOF (F35 Lightening) Arduplane binaries with Crossfire enabled?

Thanks in advance

1 Like

Try to connect the rx on SERIAL2 instead.

1 Like

Thanks Markus, I’m quite positive CRSF telemetry is supported on V1 as well, need to check with TBS.

Edir: at least one user reported success with a MicroTX V1 Passthrough telemetry over CRSF (crossfire)

1 Like