Passthrough telemetry over CRSF (crossfire)

I used a non-csrf copter today (frsky r-xsr with telemetry over s-port) with the new csrf script 1.9.1beta1 and managed to crash the script when going into auto mode (Taranis X9D+ 2019). It gave me an error description but I was preoccupied at the time. All other modes that I tried worked fine (stabilize, alt-hold, loiter) but on going into auto mode not so much. I didn’t take the time to write down the error as it was cold and getting dark; I’ll go back out tomorrow to repeat it. I turned off the csrf telemetry in the script options for this model on the taranis, so that’s not it. Any other ways this beta script has been changed that would affect the frsky telemetry in auto mode when flying a mission?

I have found the issue. I had to press the menu button and long press the page button to go to the script page. Sorry for being a pain.

Thanks. now I just need to modify the serial cable.

1 Like

1-Good news, finally got it working after reset everything.
tried to replicate the issue and went step by step with my old settings which i thought had no relation with it and i think it had something to do with the arming settings, i have a throttle cut so i disabled arming through rudder and this seemed to cause the issue because when i reverted back to the default to arm by rudder Yaapu started working, i am still not understanding the relation but happy to get it working.
2-one small problem i am encountering is with the voice messages regarding the flightmodes, its announcing the wrong flight modes and also the text is something else for it, mostly announcing copter modes like altitude hold etc when i flick for example for cruise mode it says acro mode etc while in MP it shows the correct flight modes tried the PX4 flight modes option as well in Yaapu still the same, and i am sure i am flashed the arduplane not the copter

Hi, you can reliably crash the script by switching to auto mode? hmm I’ll have to try on my radio, I happen to have an X9D 2019.
r-xsr with which firmware and version: sport, fport or access?

Hi, there’s still something not working, fightmodes depend on frametype which is periodically sent, please run the “debug crsf” lua script against this setup so we can see which telemetry packets get through

here it is: (797 Bytes)

frametype starts at 0, then 12, 13 and 14, all copter frametypes, 14 is hexacopter, so the script is working all right, seems the problem is on the FC

so is it some setting in MP? ive left most of the things to default except osd settings and choosing which channel to use to change flight modes thats all and the recommended settings to make Yaapu work

Really looks like wrong firmware, copter vs plane

Hi Alex,
maybe not the right thread but I am hanging on this “emulated wheel channel”.
How set this on the Hours?
I have try a cannel on the mixer menu (for example CH17) and programm a switch with -100 0 +100.
But no sucsess on the zoom level of the map.
Could You push me to the right way?
Cheers, Markus

Hi Markus, should be straightforward, I usually assign RS to channel 31, then in Yaapu Config select channel 31 to emulated wheel channel, please note that the zoom will change only after about 1 second, the idea is switch high increase zoom every 1 second, switch low decrease every 1 sec, switch mid no nothing

ok bit more info: error is:
bad argument at #1 to ‘match’ (string expec
and that’s all the room on the transmitter screen. r-xsr with ACCESS v2.1.0 configured to use sbus & sport. When that happens is there any way to re-boot the script without power cycling the transmitter?

strangely even inside the Taranis screen it says Arduplane not copter.
should i update the fw with MP normal fw update as you said they will now support the Yaapu telemetry script?

Hi guys, I know I’m close to getting this working but I think there’s some little detail holding me back. This is my first dive into Crossfire so why not go all the way… It looks to me like I’m getting telemetry but for some reason it’s not displaying properly. The “no telemetry data” message won’t clear in spite of the messages coming in the background and the telemetry data page showing live updates.

What I’ve done so far: Basically started from scratch.

Open TX 2.3.11 (TX16S)
Crossfire Micro TX V2 - with nano RX. Both upgraded to latest 4.10. I’m using CRSF TX/RX. And I’ve turned off RC over Mavlink. 150hz.
Arducopter 4.1.0 Dev (Latest build as of yesterday)
Matek F405-Std. I’m using Serial 1 (TX/RX 3)

I haven’t flown it, but according to MP all RC functions seem to be working fine.

I’ve verified CRSF is yes in the yaapu script settings.

Any hints or suggestions?

@Allister did you set the RC_OPTIONS bit to turn on PT over CRSF?

I did. I set it to 288 (32+256). But I’ll double check tonight that I didn’t do something silly like forget to “write parameters”.

Edit: yes, it’s 288. I also did a quick test on 256 and no change.

Finally, I got it working :slight_smile:

To make a long story short, I’m using a Matek H743-WING and it sounds that the UART 6 (SERIAL_7 into Ardupilot) on this fc does not use DMA. So, I connected the rx to the UART 4 instead (SERIAL_6 into Ardupilot: SERIAL6_PROTOCOL = 23, SERIAL6_BAUD = 57) and it started to work as it should.

I was about to give up! So, I hope it will help other H743-WING users.

Thank you Alex as well as other contributors for the time you are spending about developing and supporting Ardupilot. This is very appreciated.

Guylain Plante

1 Like

I think I’ve had a victory. I moved from TX3/RX3/SERIAL1 to TX4/RX4/SERIAL2. And of course set SERIAL2 to 23.

I noticed that on the F405-STD Matek called TX3 a USART and TX4 a UART. In my naivety I just thought that was a typo, but no this seemed to fix the problem I’m not so sure. Is there a difference between UART and USART?

The only things I noticed about the telemetry was flight mode changes seem slower than with previous Yaapu installs I’ve used. And the script did crash on me a couple of times after I got it going. I’ll keep watching to see if I can find a trigger or notice what was happening when it crashed.

1 Like

After allot of sleepless hours i think i finally got it to work, now flight modes are correct and the map is moving smoothly and all data shows on screen.
i did recheck i was in arduplane not arducopter, i think it had something to do with forgetting to write the correct channel for flightmodes after a reset, thanks for putting up with me @yaapu
one last query, i downloaded your custom firmware from ardupilot latest builds what i dont understand is when i download the 4.10 latest from your github the folder has a different structure altogether i dont understand how can that be used, if possible kindly let me know for future use

1 Like