Pass through Frsky telemetry not working

I am using 3.4.6 which claims to support Frsky passthough telemetry. I have set SERIAL4_PROTOCOL to 10 with no other ports set to 3, 4 or 10, and connected the C&T cable from the Serial 4/5 port to my FLVSS voltage sensor and the X8R receiver. The radio is a Turnigy 9XR Pro with the XJT module running rev 220 of ersky9x. I followed the instructions here:

I can see the voltage data from the FLVSS on the telemetry screen on the radio, but no other info. Has anyone got this working successfully? I am beginning to suspect the cable. I also tried the cable in the Telemetry 1 port which I know works OK since it is normally used for my telemetry radio.

The passthrough telemetry requires you have OpenTx 2.2 installed on a FrSky Taranis radio. That data on the radio is only accessible to LUA, so on a Taranis, that would mean purchasing the Craft&Theory LUA screen, or alternatively, writing your own LUA code to make use of it. Sorry, but I don’t think any of this is possible on a 9XR Pro.

You can of course make use of Standard SmartPort telemetry by configuring SERIALn_PROTOCOL=4 (where n is your serial/telemetry port number). You will get much better telemetry info running OpenTx 2.1.8 or newer on your radio instead of ersky9x. All the info is on that page you linked.

That’s actually not true. Recent versions (where “recent” means “for at least a year”) of ErSky9x (the transmitter firmware that runs on the 9XR Pro) have support for the passthrough telemetry.

@rsilk, I’m responsible for that documentation. I have passthrough telemetry working on my 9XR Pro using the software versions you see in the screenshots in those docs.

I am also using a C&T cable between the pixhawk and an X8R receiver. I don’t have the voltage sensor, but otherwise my setup is very similar to yours.

Can you confirm what firmware version you’re running on the 9XR Pro?

I am using SVN: ersky9x-r220 (04:12:2016) which is the latest release version available from
It looks like you are using a prerelease version of r221. Some of the Telemetry options are different compared to 220. Have you tested it with r220?
I removed the voltage sensor and connected the C&T cable directly to the X8R and then I see “NODATA” on the telemetry heading screen.
I have a HobbyKing Pixhawk so my cable has the microJST connector.

I have tested it with r220 successfully. I’ll boot back into that version later today and produce some screenshots just to verify the settings.

Even without the smartport cable, you should be receiving some basic telemetry from the X8R including receiver voltage and RSSI. Is that working?

Yes, RSSI and RxV are both displayed on the telemetry page without any smartport connection to the X8R.
If I connect the FLVSS voltage sensor to the X8R smartport, I also get total voltage Ctot, lowest cell Cvlt and individual cell voltages V1-V3 shown.

Apologies, I thought this was an OpenTx thing - thanks for the clarity. …and glad I could get you guys talking

Yes, RSSI and RxV are both displayed on the telemetry page without any smartport connection to the X8R…

That’s great. That means we know that (a) the X8R is transmitting telemetry correctly, and (b) we know that your 9XR Pro is receiving the telemetry. That strongly suggests that your pixhawk isn’t transmitting telemetry for some reason.

Can you post a parameter dump from your pixhawk? And also use eepskye to dump the config from your transmitter and post that as well? Thanks!

I don’t have a usb cable that fits the radio. Can I get what you need from the SD card using eepskye or the actual files/folders? If so which folder/files do you need?

Arducopter 2017-06-10 Frsky telemetry.param (10.1 KB)

I don’t see anything obviously wrong there. Here’s a short video I made last night. I apologize for the crappy lighting. The 9XR Pro is running r220, and the pixhawk is running a recent-ish 3.5 rc (rc6, maybe?). The key demonstration here is that you need to reboot the pixhawk for changes to serial#_protocol to take effect. The particular sequence in this video is:

  1. serial4_protocol is none (-1). 9XR shows “NO DATA”.
  2. change serial4_protocol to frsky passthrough (10). 9XR still shows “NO DATA”"
  3. reboot pixhawk (remove power, re-apply power), and wait for boot to complete. 9XR is now receiving telemetry.

Were you rebooting after making the configuration change? If you follow the above process, do you still see the same problem?

I disconnect the battery every time I change any serial port parameters and the problem is still there. I suspect the cable is faulty so I think I will ask C&T to swap it for another one.
Thanks for taking the time to help.

After replacing the C&T cable, I now get Telemetry on my 9XR Pro! :grinning:

After replacing the C&T cable, I now get Telemetry on my 9XR Pro! :grinning:


I’m glad things finally worked out! Please let me know if you think any parts of the telemetry docs for the 9xr pro could be improved!

Thanks Lars.
I think the docs are very clear and complete. I would use the current release build for your screen pics :wink:
I notice in the arducopter docs that GPS heading and GPS speed are not available in the current implementation of native Frsky passthrough protocol. How do we request they are added to the table?