Parameters not saved AP_Periph Matek CAN Node L431


Problem came back sporadically. See second post please.

I had a problem with AP_Periph firmware updating.
I solved the problem but i was not able to repeat it and find out the reason for it. :frowning:

I updated a Matek Can node L431 (the small one) to the latest beta dshot firmware.
Unfortunately i initially tried doing it with MP and CAN over MAVlink instead of SLCAN.
This takes forever in my working environment and therefor i stopped the update. After a few tries i remembered that i solved that problem already by just using slcan.
It worked fine and i set some parameters without problems.
But then it started that i could only change parameters temorarily. After a reboot they were always gone!

I flashed different firmwares

  • 1.4.1 stable dshot
  • 1.5 dev periph
  • 1.4.1 stable periph
    all of them several times.
  • tried it using a fresh and clean arduplane version 4.3.4 and nothing attached but the Pixhawk4 and the cannode directly with a short cable.

But without success.

Finally the first update i tried via DRONECAN GUI solved it! ( I dont like that there is no update progress bar)
I have no idea why the updates over MP did not solve it but DC-GUI did.

Is there a possibility to check the firmware/Parameter variables on the AP_Periph?
If i ever encounter it againโ€ฆ

Best regards

I got the problem again.
After i tested to repeat the problem unsuccessful I flashed the 1.4.1 stable dshot firmware via Dronecan GUI to continue with my productive work.
โ†’ all parameter changes reverted after reboot.

after another reboot (no reflashing!!!) it worked again.

What is happening here and what can i give you in order to figure out the cause?

Parameter files: