Servers by jDrones

Parameters are missing from firmware

Using a tablet with OTG cable (works fine), latest qgroundcontrol, 500 mw sik radios with aircraft set up with a Matek F765 controller.
Radios connect, parameters appear to download but I get a dropdown that says “parameters are missing from firmware. You may be running a version that qgc does not work with properly, or there’s a bug in the firmware.” When I clear the window I get another that says, “1: compass primary”.
Too weird.
Mission Planner is a disaster- no com port is opened when I connect the telem. radios, and I get the “Oops” sound. No connect, of course.

That’s because the version of Ardupilot you are running doesn’t have a COMPASS_PRIMARY parameter. What version are you using? Ignore it or use Mission Planner. Select the comp port the radio is on with baud rate at 57.6.

Thanks very much, dave.
My AP is 1.3.74,
My qgc is 4.0
Unfortunately, of all my sik radios (6) only one will produce a com port in device manager. It’s the 100mw 3dr clone. The others are 500mw, and produce the “not good” tones when plugged into usb, and no connect or com port.
I’l see if I can get it to work with qgc–my preference, since I’m using an android tablet.

I meant which version of Ardupilot. Copter 4.0.4, Plane 4.0.6, a -dev version?

Those 500mw telemetry radios are junk IMO although they should connect. The best joke I have seen about those radios is they will work great if they are towed on a long lead from the craft…

Use a QGC daily build if you want to user versions of ArduPilot firmware which were released after the QGC stable build went out. And then it should all work fine.

1 Like

I’m using 4.06 stable.
There are an amazing variety of sik radios, of all levels of quality and price points. I doubt that they are all crap, though I admit my experience so far supports your judgement.

Thanks very much, DonLakeFlyer. I’ll do that. If I can find a way to load the daily build onto my tablet. Google has the field locked up—if it aint in play store, it’s hard to get. Advice?
Still find the lack of a com port or a connect on AP pretty strange–
I’m an old ham with good skills with vacuum tubes, and not so much with microprocessors :laughing:
Edit: Found it. Done, and thanks again.

Daily builds are available from the store. Just search for QGroundControl daily

I found the daily, and installed same. I like the interface and layout changes, but I’ve come to believe it’s not qgc that’s
causing trouble. Yes, the radios do vary a lot in quality, and that probably relates, but here’s the state of things after a lot of work:

  1. Using the daily build OR the stable, I can download the parameters to my tablet using the telemetry radios, but I still get a warning about the compass parameter, and an incomplete setup element (compass), but what’s worse is that once the parameters are sucessfully downloaded, communication with the FC (Matek F765) just stops, -no horizon shift, no data on the HUD. Remember I bent the usb connection and fixed (?) it. I also get a “stuck thread” warning—what is that all about? Searched on it, but the results were in Martian.
  2. Using Mission Planner, the telemetry radios, except for one, do not create a com port on my PC-- so no communication with either QGC or MP. Sounds like a driver is missing from the PC, but not sure. Just downloaded a new copy of the kiss stm32 drivers- will see.

In summary (finally!) I think it’s a multiple problem. I think the Matek FC is buggered,because of the com loss after parameter download and “stuck thread” and I think my PC is missing one or or more drivers.
Very tired of this- thanks for sticking with me throughout, all.

Servers by jDrones