Parachute problem ArduPlane 4.3.4/Matek H743 V3

Good day. I use Arduplane 4.3.4 on Matek H743 V3. I tried to set up the parachute, I did everything as indicated in the documentation, I set up RC and Servo6 on channel 6. Guided by the documentation, I decided to check the operation, I turned on the engine in the stabilization mode, while the minimum height for the parachute is 10 meters by default, the parachute switch is set to 3 positions. Through the control panel, I open the parachute and it works, but the engine continues to rotate, the height of the plane is less than the minimum (it is standing on the table). Also, the parachute is activated when the aircraft is not armed. What is my mistake? What is the problem?

Please post the .bin log.

Here are the logs. Moreover, at first it worked unexpectedly, I changed some settings, it stopped working, then I returned those settings again when it worked, but it no longer worked ((
Parachute on channel 6.

What, no idea? No one uses a parachute?