OSD not displaying with a vista and DJI Goggles 2

I am running Arducopter 4.4 on a Raspberry Pi 3b+ with a Navio2 shield. I have a Caddx Vista running the latest v01.01.00.00 firmware for the DJI Goggles 2, connected to uart serial 2 for OSD. According to DJI release notes, this firmware supports Canvas Mode.
I cannot get any OSD elements to display, but I am getting telemetry between arducopter and the vista; the stock DJI OSD will display full pack voltage in the bottom right.

Check your wiring. Most common mistake is to forget to connect the UART RX->TX and vice versa.

I ca confirm that the Vista and Goggles 2 work reasonably well with ArduPilot.

I can confirm the uart is connected correctly. If it wasn’t, I wouldn’t be getting the battery voltage in the goggles with the stock goggle OSD.

I’m not so sure that’s true. The Vista takes full pack voltage, right? Isn’t it possible it’s transmitting that on its own?

A vista gets voltage via MSP over uart. If it wasn’t connected properly, it would read “N/A.”

What MSP and OSD settings are you using? Regular MSP or Displayport?

I simply followed this guide for MSP:


I’ve got:


and I think that was about all apart from setting the goggles to custom and moving some items around on the screen.

1 Like

I believe is something related to Linux uart
I tried in the past using beaglebone with caddx and I couldn’t get the osd working.
Meanwhile in the chibios boards is working fine.

2 Things:

  1. Edited due to incorrect info.
  2. Assuming you have the correct UART connection, have you enabled custom OSD display in the goggles? I forgot exactly where but it’s under the display menu.

Again, unless things changed with the vista running O3, you cannot get battery voltage in the goggles from a vista without having a working uart. There is no voltage sensor in a vista. It gets this information via Multiwii Serial Protocol (MSP) from a flight controller. If no uart is connected or the uart is configured incorrectly, the goggles will display “N/A” rather than a voltage.

I have battery voltage in the goggles so the uart is connected correctly. I can even get it to display “N/A” by changing the OSD_TYPE parameter away from MSP in Ardupilot.

In the goggles 2, I have the option for HD OSD or standard and I have tried both to no avail.

  1. Even without correct UART connection, the lower right voltage OSD will still display whatever voltage that is powering the vista unit. Like Yuri said this is DJI’s OSD you are seeing.

unfortunately, this is incorrect, the goggle’s OSD in the bottom right corner will only display voltage coming through UART, NOT from the voltage that is powering the Vista or the AU, otherwise every FC or system that powers it through a regulator would be useless.

This is in fact an indication that the UART is wired and connected properly and there is some communication.

so I just went through this having issues and these are settings that worked running latest goggles 2 firmware and the latest vista firmware to get them to work with goggles 2. I just took out the vehicle and confirmed these are working params with goggles 2 and caddx vista. You do not use SERIAL_PROTOCOL=33 with the goggles 2 as they support MSP and do not need the the FPV.WTF/canvas mode stuff which if I am not mistake was the reason for 33. Now that most goggles natively support MSP the option needs to be SERIAL_PROTOCOL=42. There is also no button to toggle on the custom osd in dji on the g2 because they support MSP now.
MSP_OPTIONS=4 this seemed less trivial than getting the other settings right.
Baud 115

I stand corrected. Memory confused the goggle voltage with aircraft voltage. I’ve corrected the post.

Oscar always writes top notch content. Although much of this is Betaflight focused, most of it should apply equally to ArduPilot, since both use MSP OSD.

Review: DJI O3 Air Unit and DJI Goggles 2 | How to Setup and Best Settings - Oscar Liang

I wonder if you’re suffering from some firmware incompatibility issues after all the DJI/Caddx drama? Oscar confirms the hardware does work together and offers some advice regarding firmware versions.