OSD flight data disappear when arming

I am running Minim OSD V1.0 on ArduplaneV3.2.3. Power supply to OSD is 2 stages, ie. 12V to video side and 5V from APM2.6.
OSD firmware is R800, Char set mcm

As soon as I arm the motor by pushing the rudder stick to the right, the flight data disappear on the display. This does not happen every time.
Pressing the OSD reset button makes the data reappear. Powering up the APM BEFORE or AFTER powering up the video Tx does not make any difference.
Please help.

Another OSD related issue : –
On the same platform as above, after powering up both the APM and the video Tx, the flight data very often do not show up, only after pressing the OSD reset button do they appear.
Sometimes the flight data appear right away without pressing the OSD reset button. Again, the order for powering up the APM and video Tx does not matter.
This problem has been bothering me for 3 years. Can anyone shed some light on this issue ?

SR0 and SR1 (default) setting of parameters as follows :–


1 Like

I had an issue like this on a MinimOSD when I changed my FPV camera to a higher resolution one. Sometimes the OSD would appear and sometimes not. It is a problem of the MAX7456 chip used I think. I dont know if there are settings that you can sed to the chip to improve the situation or not. Meanwhile you could try another camera and see if that solves the problem.

1 Like

It is definitely a camera problem.
I have some nice expensive (for FPV cameras) Sony cameras but they will NOT provide an image at boot.
If the camera is unplugged the OSD fires right up, no problem.
If the camera is attached I get a nice image but no OSD.
So I put a push button switch on the video line.
Boot up, press button to momentarily break video, and OSD appears.
Not an ideal solution but it works.

1 Like

Not a camera problem. Not an Osd problem. It’s a wiring problem. I had exactly same thing. It’s noise in the wires affecting the chip. I tried toroid rings; no difference. Tried an in line filter; no difference. I ended up separating the camera and osd circuit from the circuit the main escs are on. You need to avoid the circuit loop where escs spool up introduces noise

Agreed with Tsayta - this is a typical problem when you’ve got noise on any of the power lines to the minimOSD. When arming, the servos typically jolt and or the ESC powers up and this could spike your minimOSD power lines if they are too close, or shared.

I had same problem no matter what camera I use, as I changed different
camera before.

I experience same problem (flight data disappear upon boot up) with
different cameras,

such as Mobius, Keychain 808 #16, Xiaomi Yi Action camera or Sony board

until I press OSD reset button, then the flight data appears.

Hi Tsayta,

Thank you for yr input. Could you please share with me the details on how
you separate the circuit ?

Appreciate if you show me a rough wiring diagram (hand-drawn is sufficient).


Hi Tsayta,

Further to my earlier email, pls also find attached the diagram according
to which I do the wiring of the OSD.
As stated in the diagram, I connect the OSD to the 3 pins soldered to the
UART0 port of APM. The other side of OSD is hooked to camera and video Tx.

I thought connection in this way is already separated from the main ESC
circuit. Am I correct ? If not, pls shed some light on how you did it.

Thank you.



Do you have any suggestion to solve this problem ?

Appreciate your comment.


I can’t see the diagram you’re referring to?

Are you referringbto the link ? I did not attach a photo.