Osd data partially refreshed/frozen

Hi all,

I am using a micro minim osd and an ardupilot micro with last firmware available for tricopter.

I experience a weird behavior, some data are ok like the horizon or the compass but some other are “frozen” like the battery voltage and current but also the rc channels.

These frozen data are updated only when I arm the drone, they are updated only once and then they are frozen again. If I disarm and arm again, data are updated again once.

If I connect the micro APM to mission planner via USB, “No data” is shown on the OSD, then when I disconnect the APM from the USB cable… The OSD works perfectly until I disconnect the battery.

I tried several releases of the minim osd extra firmware (R800, R726) and I set a delay of 10 sec for telemetry.
I also tried to change “SR1” parameters with no effect.

I don’t use telemetry module in // of the OSD.

Maybe the problem is in the ardupilot code…

Any help would be appreciated.

Thank you in advance for any help.

For all I know you can’t use USB and telemetry (=OSD) with the APM at the same time.

Thank you for your answer.

I know this but what I am saying is that the USB connection/disconnection seems to start the mavlink feed to the OSD.

Previously I changed only SR1 parameters but now I found this


I followed the instructions and it made things better, now only the battery voltage and current are frozen but other data are displayed fine.

If somebody could guide me to which data I should change to get the battery voltage and current it would be great :slight_smile:

A friend who has an APM 2.5 running ardupilot 2.2.1 and a minimosd running minimosd extra R800 has the exact same problem.

My friend had this setup for some time now.
Since his OSD is in parallel with a telemetry module he never noticed the bug because when the telemetry module is connected to the PC, the OSD works fine.

The conclusion seems to be : If one uses an ardupilot and a minimosd running minimosd extra with no other telementry connection than the OSD, the voltage and current are frozen and refreshed only once when the drone gets armed.

Did anyone found a way to make this work?

Alright, I found a solution!

I use ArduCAM instead of MinimOSD extra and it works almost perfectly, the only problem is that it shows a wrong overspeed message when I switch panel and the flight mode is empty.

Besides all that it works perfectly whatever I put in SR1 parameters.