Orange cube doesn't recognize compass on Here 2

I’m setting up an orange cube with a Here 2. It doesn’t seem to recognize the compass on the Here 2 or the internal compass in the cube. When I try to calibrate the compass it doesn’t populate any percentages in the calibration window. Is anyone else experiencing this?

I flew my Orange Cube with Here, Here2 in both I2C and CAN mode, and now it’s sporting a repurposed CAN GPS from an Emlid Edge. Not a single mag trouble, even with the GPS double-taped ontop of the Cube.

In my case, the internal compass in the Orange Cube is recognized, but the compass in Sirius RTK GNSS is not.
Have a look at the parameters COMMPASS_DEV_ID; COMMPASS_DEV_ID1 and COMMPASS_DEV_ID2.

You have that Sirius connected to the GPS2 port ?

I ordered mine without the mag - bad decision in retrospect - but that RN3100 should be recognized. Doesn’t it show in the HW List ?

I tried GPS1 and GPS2, both negative

I’m using the CAN1 port. @ThePara what firmware are you running on your cube?


Could you try setting the BRD_BOOT_DELAY to 5000 (5 seconds) to see if this helps. It may be that the autopilot is starting up faster than the compass so the compass is not ready to respond when the autopilot first probes to see if it’s there.

This only explains the external compass though, the internal compass not working is odd. Could you post a log file?

I have set the BRD_BOOT_DELAY to 5000 but the external compass is not recognized either.


Can you post a log file (preferrably the .bin version) so we can see the parameters? The main thing I’d like to check is that the UAVCAN configuration has been done correctly. I’m not actually very familiar with what needs to be done to enable a CAN compass but let’s see the log file in any case.

I do not use a CAN connection. I have the Sirius on GPS1 connector. So the compass is on I2C.

Are you sure you wired that correctly !? Because GPS1 on Cubes is an 8-pin connector (including arming switch and led) and the Sirius factory connector is 6-pin.

I’m sure I wired Sirius correctly. I have also tried GPS2 connection and there the compass is not detected also.

Yesterday I install the first Time an Orange Cube. All went fine but unfortunately it doesn’t recognize the 2nd internal compass. The external on I2c and one internal was straight away there but the second internal was missing. Anyone got an Idea?

look at the parameter COMPASS_TYPEMASK

wich one do i have to tick for the Orange Cube?

Tick everything EXCEPT the CAN option. When you tick it DISABLES that driver :slight_smile:

So, disable all the drivers except CAN?
The external wich is coming from the here+ is an I2c one…

it a little bit confusing what you say, or i dont get it.

First of all try the latest Beta and the new compass settings if you can as that’s much more user friendly.

There are some things to remember with multiple compass sensors.

Ardu with prioritise compass sensors as follows

Internal SPI
I2C External

however there is a limit of three in current release so this means if your autopilot has 2 internal ones these will take priority over the rest.

The latest beta allows you to easily move the compass order around and is dramatically improved

There is also some quirks with a CAN and one on GPS 2 as well and I’m going to test that my self.

1 Like