Opt out of mode change dropdowns?

The latest MP version has drop downs for mode changes at the top of the data page which make it extremely scary since there is no confirmation needed to enter any mode at all. This is extremely problematic for commercial applications where a user could accidentally enter a mode with a single wrong mouse click.

I’m very much hoping that there is a way to opt out of this, although I’m not seeing it yet, or that I’m on a beta version. I tried removing the beta and using the installer for the latest stable. It reads 1.3.7530.26934. Is it possible to remove this from the interface?

I also agree that this could pose an issue if there is a mis-click and the craft is put into the “wrong” mode. Any way to add a “set mode” button to verify the drop down - similar to how it is done in the actions tab?

That would at least add the standard protection, but why have it up there at all?

For me it is actually useful if I am trying to change modes while having another tab “messages”, “quick”, etc. opened up to monitor the aircraft. Not that big of a deal tho - just something nice to have.

I can see that being helpful, but not at the risk of non confirmed mode change. There should be a ‘Set Mode’ confirmation at the top like you were saying.

Yeah, definitely think there should be a “set mode” regardless if people are using or not using it.

that is an example plugin which is loaded from the plugins directory. all you have to do is go to the plugins directory and delete files named example that will make it go away.

you find the it under the Mission Planner folder in Program Files (x86)

1 Like

Thank you very much. That seems to have worked perfectly. I just removed them all. Is there any resource that would give at least a brief description of each example plugin?

Since these are coding examples, all description is actually in the code. You can open .cs files in notepad…

Excellent. Btw, the Load and Append is a beautiful thing. Thank you!

hello i have the same problem i removed it and download it again and delete example files and it still the same error

setup > advanced> and click param regen

Also struggling with a similar issue. Parameters upload, but no flight modes. Also, the parameter description, Range and Unit values are missing in the Parameter Tree.
I’ve tried various MP versions, deleting and reinstalling drivers (using MP driver clean) and still no luck.
I’ve been using MP for many years, so am pretty good at fault finding (usually on my side), but haven’t come across this issue before.
@Michael_Oborne - tried Param regen, but also get an error