Only two wheels turning, no speed control and Radio control

Hi Dave
In this case that is not true because I am powering the 5v line with another power supply however, LEDs should light with either 5v or 3.3v.

The Pixhawk 4 has the FMU pins on a JST-GH connector and they are connected to the servo connectors on the PM07 with a 10pin JST-GH cable.
5V supply is not neccesary for GPIO/relay pins. 5V is only needed to supply a device connected to the power rail of the PM07, like a servo. If you have already configured the “MOT_PWM_TYPE” parameter as “brushed with relay”, you will not be able to switch those relays manually through Missionplanner.
The high voltage on the signal pin will be 3.3V.

Hi Sebastian
Yes, you are correct about the JST-GH cable. I did not know that power to the power rail of the FMU-PWM-out is unnessary for it to work in relay mode. Would you mind looking at the previously attached picture of the PM07 and confirm that I should be have the direction pins of the motor controllers connected to pins S5 & S6 of the FMU-PWM-out? I have now connected these pins and on an osciliscope I can see that there is no output on the FMU-PWM-out pins 5 & 6. I have attached a new parameter file.
Mower-motor drivers-GPS-02.param (14.4 KB)


You have set Relay1 and 2 to pins 50 and 51, but (as can be found in the documentation and previous posts) they need to be set to pin number 54 and 55, the pins driving AUX5 and 6. Pins 50 and 51 will not work, because AUX1 (50) to AUX4 (53) are configured for PWM output (BRD_PWM_COUNT 4)

A suggestion. Update to Rover V4.2.0-beta3 (latest beta) and you won’t have to worry about the BRD_PWM_COUNT parameter because it’s gone. Outputs are individually configured with the SERVOx_FUNCTION parameter.

1 Like

Thank you for that clarification Sebastian. My difficulty was in understanding the correlation between the relay pin numbers in Mission planner and on the PM07. With your guidance and patience I now have it working. I may need more help getting it to run a mission automatically now.

Glad you got it working. Please feel free to ask, if you have further questions.