Only 2 motor working fc skystar H743 hd

Recently buy new fc SkyStars H7 HD Dual Gyro + KM60 BLHeli_32 ESC 30×30 Stack
Try install arducopter firmware latest arducopter_with_bl.hex
APMVERSION: ArduCopter V4.3.0-dev
All setup done try to motor test but only 2 motor work 3,4
4 motor test in betaflight all work perfect







param list.param (19.4 KB)

Trying this setting


All motor spin but spining full throttle trying mission planner motor test tab 5% throttle and test a motor all motor spin full throttle and motor hotting

https://drive.google.com/file/d/1CqPIsz0akqlsLPvY7_nBZGD3am--e7RX/view?usp=sharing

Set
MOT_PWM_TYPE to 6
SERVO_BLH_OTYPE to 0 (default)
SERVO_BLH_MASK to 0 (default)
SERVO_BLH_3DMASK to 0 (default)

Then after connecting to Mission planner what does this message say in the Messages screen?
RC out

1 Like

I dont see tomorrow check and try your setting share results

Bi-directional dshot support ?

You are using the Bdshot firmware? And, you should be using the latest Stable or beta version not the Dev version unless there is a compelling reason to do so.

2 Likes

That doesn’t tell me anything. Why bother with Betaflight if you want to run Arducopter? Did you flash the Arducopter Bdshot version of firmware to the Skystar Board? It will show in the messages screen also. Post a screen capture (not a photo) of the messages screen after connection.

I know
I see article what a saying

There isn’t a bdshot version of this board - they are sending me one

3 Likes

OK, no Bi-directional Dshot and I see why you are using the -Dev version. Anyway from default you only need to set these 3 parameters for Standard Dshot:
MOT_PWM_TYPE to 6
SERVO_BLH_AUTO to 1
SERVO_DSHOT_ESC to 1

Trying
MOT_PWM_TYPE to 6
SERVO_BLH_OTYPE to 0 (default)
SERVO_BLH_MASK to 0 (default)
SERVO_BLH_3DMASK to 0 (default)

And

MOT_PWM_TYPE to 6
SERVO_BLH_AUTO to 1
SERVO_DSHOT_ESC to 1

Same issue

Right because Chan 1,2 and 9 are configured for Neopixel not motor outputs. I suppose because those are all on Timer1. You could use Outputs 3,4,5&6
SERVO_BLH_MASK to 252
SERVO_BLH_OTYPE to 6

I wonder if you can simply disable Neopixel by setting NTF_LED_TYPES to 0. Might try that 1st.

Change the function on SERVO9 to -1

1 Like

For future reference is that because 1,2 and 9 share the same timer?

Yes. 1&2 are using complimentary channels so if I do a bdshot version I will fix this (bdshot can’t use complimentary channels)

3 Likes

Changes
MOT_PWM_TYPE to 6
NTF_LED_TYPES to 0
SERVO9 to -1

All motor test work fine :+1: