Oneshot not arming motors

Hi there

Just updated all my ESC’s to BLHeli 14.8 in order to use oneshot125 on my arducopter. I set the PWM type to 2, calibrate radio and ESC’s, which is working absolutely fine… All motors starting exact same time, arming at once and everything, but when i disconnect the battery, and reconnect it, and arming the motors on the safety switch, not all motors are beeping and arming. Some times no one will start whatever i do to the remote, sometimes 5 out of 6 starts. Really don’t think this is an ESC problem as they are all arming fine and everything, when calibrating…

Anything i forgot?

I didn’t have success with oneshot a while ago and disable them, I didn’t read nothing if the issue was solved, If someone clarificate if it was solved is welcome. If you wait, all esc armed at last and fly well but I ignore the risk carrying that issue.

There seems to be a fix in 3.4.0-rc3 release notes. I use Oneshot125 on my quad with DYS xs30a ESCs, they arm and spin up fine each time.

1 Like

Okay. It seems like there is a fix on its way. Thanks guys… Just wanted to know if I did something wrong, but it looks like a common problem…

Hmm… But I am running 3.4.2? Do you run 3.4?

I’m running 3.4.2 rc2 currently.

I’m running oneshot ( pwm_type=1) . My motors arms in a random way, most of the time under 1 min, so it is a good time for it to warm up sensors, so I decided that I can live with it.

With oneshot125 my motors suffered from random twitches even disarmed. It seems that it could be a blheli problem. I’ve posted twice as so @LuisVale but no one has answered us.

There is also a github issue which was closed. Therefore I don’t believe there is anyone looking at this issue. All I can say is that it used to work at some point between 3.3.3 and 3.4 so I’m really unsure where the problem is.

If it is an issue, I would recommend you to disable oneshot.

Issue is that when measuring the signals coming out of the PixHawk everything is correct, so there must be a setting that we might be missing on the BLHeli config.
Hadn’t the time yet to follow up the issue, but I’ve been with Tridge at more than one occasion and having the outputs logged by a signal analyser and no probs…

So you are saying, its a missing parameter in the BLheli and not a bug in neither the BLHeli or the ArduCopter? :slight_smile:

It can be a lot of stuff. Some are using this setup without issues. I have 2 different sets of ESC’s -different brand and models, and on one set the issues are almost unexistant, only a minor delay between the arming beeping on the ESC’s. On the other brand of ESC’s it’s very similar to what you’ve experienced.
As the timings are more critical using Oneshot the quality of the components can also play a role, but without further investigation it’s not easy to determine a definitive root cause (or several :slight_smile: )

Okay! Thank you for the very clear answer. Do you know if this is anything they are going to investigate (are you a developer?), or do they expect people to find a workaround, as it proberbly not is the ardupilots fault? Is there even a difference in a medium sized hexacopter when flying oneshot125? Or is it just something i have told myself?

Pursuing this further would involve measuring a lot of different ESC’s with signal analysers and oscilloscopes to get a good answer.

At this point in time I believe we’ve covered the PixHawk side of things (both standard 3DR PixHawk and AUAV PixRacer) and the signals they output are perfect according to the specs (both PWM, OneShot and Oneshot 125). The variance in results when using different brands of ESC’s with the same BLHeli firmware versions and the exact same settings and the exact same PixHawk is what IMHO is strange, but I don’t have more ESC’s to test…If someone with a wider variety of ESC’s and the measuring tools could also look at this we could draw a better conclusion.

The copter dimension should not be an issue here, but some could claim that cable length can play a role, but I won’t go there :slight_smile:

I have a 250 quad, 330 quad, 580 quad, 550 hexa, 900 hexa, 1000 octa, and the first 4 have BLHeli capable ESC’s flashed to the latest version available, and the Oneshot problems are different between all of them. Unscientific note is that the behaviour is better on Silabs based ESC’s and worst on the Atmel based.

About the variance on ESC’s let me give an example.

4 ESC’s same model, same brand bought from the same vendor at the same time, so assuming from the same production batch.

PWM output selected on the PixHawk and PWM_MIN and PWM_MAX set to 1000 and 2000. Values confirmed with the signal analyser on the PixHawk output channels.

Set the PixHawk to ESC calibration. Follow the entire procedure and confirm the output values on the signal analyser during the entire process. The ESC’s respond to the high PWM on power on and enter on range calibration mode and finish the entire procedure without any issues.

Now go to the BLHeli suite and connect the ESC’s and check which values each ESC determined to be PWM_MIN and PWM_MAX.

One would expect 1000 and 2000, right ? Wrong, variance in range can be as much as 50/60 both on min and max…

If things were perfect we could set the range on the ESC and on the PixHawk and everything would be perfect (been there, done that)…

edit: when I say signal analyser I mean logic analyser :slight_smile:

Okay. I understand. I can see the problem in fitting the same software on multiple hardware. Of course it will never be the same on each ESC’s. Didn’t think about that. Thank you for making this clear… I think i will stick without oneshot enabled.

Thanks! Will post a youtube video as discussed on facebook… Sorry for the dobble post…

For a medium sized hexa the Oneshot /Oneshot125 should not be an issue, because “usually” these copters do fly less aggressively than a 250 racing quad :slight_smile:

btw: this was a few months ago

Yes, i did see that one… Its almost the same as my issue…

Remove the props !!!

:slight_smile: :slight_smile: :slight_smile:

Sorry the offtopic. you dissasemble the safe button to fix in that hole?

I do the same with the button on mine, just drill a hole and make it fit snug :slight_smile:

1 Like

I know i should remove the props :slight_smile: But i didn’t… I just trust my nice bird enough that it would spin the hell up on me :smiley:

No i didn’t drill or disasemble anything… Will post a picture…

1 Like