One motor won't spin on first launch

Hi guys, today I was trying to launch a “new” (actually older but newly converted) copter for the first time and encountered a problem I’ve never had before: One of the motors simply won’t spin up.

What seems weird is that I saw it was motor 4 (B - lower right when behind quad). Yet according to the log it seems like it’s motor 2 (C) whose RCOUT is not increasing on throttle up?! Here’s the log: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Motor tests before and after this occurence pass without problems, everything seems normal. Copter 4.3 stable, Kakute F7 AIO, 4x Holybro single ESCs.

Thanks for any hints, I know it has to be something simple so I’m already prepared for the solution to be a bit embarrassing… :wink:

It looks like motor2 is not going above arming throttle because the whole time the copter has been sitting the pitch (and roll) has been changing. Maybe reboot just before arming if outside temperatures are low and the copter has been sitting - this will allow the baro and the gyros to reset at the lower/stabilised temperature.

But anyway…
maybe the MOT_SPIN_ARM is a bit low for these motors and ESCs. Go back to MissionPlanner motor test and check all motor positions and spin directions (why not?) and recheck the lowest percentage required for smooth startup of all motors. Set that value as MOT_SPIN_ARM , then and add 0.03 to that value and set that as MOT_SPIN_MIN.

1 Like

Thanks, I did all that now and will try again tomorrow. Kakute F7 has always had the weird issue of gyros going crazy on the bench - always moving at insane speeds, rolling and diving, according to MP. But outside, when actually flying, my other copter running this board never had any issues.

In any case, I added some “gear” (zip ties) below the arms now, so the copter is more levelled when trying to launch. It was leaning to one side heavily due to a crude, self-made li-ion battery below the frame, which is not exactly flat. :wink:

I just checked the video I filmed (it was supposed to be a maiden flight) - it’s definitely the lower right motor not spinning, as seen from behind the quad. Isn’t that supposed to be motor4/B?

That can be from a bad GPS position too. But gyros do drift with temperature.

Yes - probably retest in MP motor test.

I did - all motors correct there, tested separately and in sequence ABCD. And yet…

Tried again today, only to encounter more strange occurences. New log: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

First there were RX/CRSF telemetry problems, and even after rebinding twice telemetry in Yaapu was still locking up. I wonder if there are issues again with Crossfire Nano Diversity receivers?

RC was working at least, so I gave it another try. This time all motors spun up correctly, but as soon as the quad had left the ground it started speeding forward, even pulling back full on pitch didn’t help.

Gyro calibration looks ok to me, horizon was level in OSD on launch. There was some wind from the back but not enough to blow away the copter. This quad used to be my most used one, until it crashed due to iNav two years ago.

Vibration looks low enough to me?

This is actually the first time I have to do some real troubleshooting in AC - my first 2 Arducopters flew well from the start, even before Autotune. So I’d be really thankful for some hints…

EDIT: sorry I havent worked with CRSF at all, I don’t think I should start advising on that.

See how desired roll and RCin1-Roll generally move in the same direction

but desired pitch and RCin2-Pitch are opposite to each other

You should reverse the pitch channel in your transmitter, check it with the radio calibration screen of MissionPlanner - From the doco:

  • for roll, throttle and yaw channels, the green bars should move in the same direction as the transmitter’s physical sticks
  • for pitch, the green bar should move in the opposite direction to the transmitter’s physical stick
  • if one of the green bars moves in the incorrect direction reverse the channel in the transmitter itself

I set up a common model with such settings and then I can copy it to a new model to be paired with a new receiver as required.

1 Like

Thanks a lot! :slight_smile: It’s a bit weird though because this model is in fact a copy of another ArduCopter which is working fine, even running same FC and RX. That’s why I’d never have guessed at something this simple. I just re-did the radio calibration and even then I didn’t notice the pitch being reversed…

As for CRSF telemetry, it worked immediately and permanently on the bench, so I didn’t investigate any further for now. In any case I think I can rule out interference in the field as other models with Nano RX always worked fine there.

Thanks again!