Onboard compass calibration won't complete with external mag

Using Mission Planner 1.3.48 here. Have a Pixhack 2.8.4. When I first connected the board, I connected only the board, no other connections to the Pixhack. The onboard compass calibration completed successfully. Then I connected the GPS module and its magnetometer to the board. Now when I run the onboard calibration, one compass completes the calibration but the second bar stops moving after a point and gets stuck.
Any ideas what might be happening?

Thank you.

I am wrestling with the exact same problem. When doing the on board compass cal with both the external GPS/Compass and the internal, the internal (I think) go to a full green bar but the external (I think) going to about half way and will not go further. If I disconnect the external (unplug), the internal will complete successfully. I tried unmounting the GPS/Compass module and doing the cal while just moving the GPS/Compass module (the copter was not moved). The green bar corresponding to the external GPS/Compass increased to halfway and stalled out. The internal green bar did not move (This would be expected since I was not moving the Pixhawk itself).

Did you have any luck figuring out what is going on?


Hi! Sorry for the early reply :stuck_out_tongue:

I gave up on trying to figure out what was going on with that. I’ve seen that problem cropping up mostly on clones. I then shifted to the CUAV Pixhack v3 and have been LOVING it. Built a Skywalker with a 70 min endurance and have tested it for over 800km in total by now. Haven’t had that issue on this new controller so fingers crossed!

Could it have anything to do with the Quality Control of the manufacturing of the boards?