Servers by jDrones

OmnibusF7V2 is not detecting the compass

(Am) #1

Hi all,
Desperately looking for help.Really want to use arducopter instead of INAV but OmnibusF7V2 is not detecting the compass(Drotek M8N GPS+HMC5883 compass combo) running latest arducopter.I tried latest arduplane too but same problem.

If i switch to INAV without touching any wiring ,then compass is detected and working.
Compass is wired to SCL/TX3 and SDA/RX3 pad of the omnibusF7V2.
GPS is wired to Tx6 and Rx6 pads of the board.
Smartport is wired to Tx1 pad of the board.
Sbus is wired to RC pad of the board.

Here is the SCA and SDL trace while bootup.I noticed that on ardupilot,both SCA and SCL remains low but on INAV,both remains high(as shown in the trace).Also on mission planner,I can’t select ‘Enable compasses’.I can’t click on it,Itried to enable compass in parameters too but no success.

Everything else (GPS,Frsky SBUS Rx and Smart Port telemetry)is working.Please help.Thanks

(Am) #2

I accidentally solved my issue.

I was trying to trace the SCL and SDA using logic analyzer and it started working(as long as USB logic analyzer is connected).So this board needs 2.2k pullup resistors connected to 3.3v.Finally compass is working.