Servers by jDrones

OmniBus Pro v2, Arduplane 4.0.3, help

Hello all,

First post. hope i am doing it in the right place.

I am running Arduplane 4.0.3 in omnibus pro v2, flying wing s800.
The wing i used to fly without any FC. And it flew pretty good. Always stable and easy to fly with 50% expos. (no dual rates needed).
Decided to give it a try with Aurduplane. (so i got a cheap omnibus, i think from BG).
(uploading the arduplane software and setting things up was pretty easy, i was even surprised…)
everything seems to be working alright. Elevons working properly both in manual and fbwa. GPS also showing the location and +9 sats most of the times.

first thing i noticed was, the plane is practically unfliable in manual. way toooooooooo touchy.
so added expos… up to 100% and cliped the pwm at the TX. (i did not recalibrate), trying to have less throus on the surfaces. still… it’s too touchy…
second thing i noticed is autotune does not save the pids values. no matter how long i run it…
third thing, (after manually finding some pids, probably not the best), i cant make tight turns…
i’ve changed the bank angle to 60 and navL1_period to 13…
still, the turns are too wide. (first thing i thought was the trough limits… are limiting. but thinking again about it, i believe the trough only limit the speed you get to the desired position)

i’ve been around the parameters and documents… and i cant seem to find a good explanaition for all this except, either i am doing something wrong (most likely) or the board (fc) is just not capable of working with the arduplane. which in turn doesnt seem correct because i see on YT others using this same board and same software and… it works. actually they even claim it works pretty good and easy to tune and all.

can some one point me what i may be doing wrong?
I have logo files… :slight_smile:

Thanks in advance,
Rui

When asking for any help it is necessary to upload a .bin file from the flight controller (FC) so people can see what is really happening.

Too touchy in manual usually means you have made the plane tail heavy.
Did you recheck the CofG after you installed the FC.
If the plane is difficult to fly in manual the poor FC is probably having a hard time as well.

Post your .bin file of the last flight for further analysis.

i used to fly this plane alot. and it was really docil. and i marked the cog. i have the same cog, and i checked, because the first time i flew it i felt it taill heavy indeed. but not today… i am sure that is not the case. wonder if vibration could be the cause (but i think one should have problems in auto not in manual), another possibility could be not enough power to the servos… and getting them lock in extreme positions…(but wouldnt i have it too when auto and changing attitude really fast??).
trying to upload the bin files…


this flight, at the end you can see i was fighting in manual… till i crashed it…


this log has a long autotune time. i believe it does not save the pids…

sorry, seems that the files were too long to upload here.

thanks for you help Mboland!!!


can you tell me the units in this aetr.ail signal? should it be the pwm number[1000-2000]? or the angle in centidegrees?
for the pwm… it’s alot out of limits.
for the angle… i would expect it to be smoother at times the plane is flying straight.

Just a couple of points I noticed looking at ‘voo_c_acc_danificado.bin’

Vibrations are excessive and need to be reduced or the FC won’t have a chance


There is major clipping on the IMU.

But in Manual mode this should not affect the planes flight as the FC is not performing any intervention.
This is curious as looking at your RCout it is all over the place, and here you can see the occasional corrections you make to keep it going.

It looks more like some electrical or mechanical problem other than the FC.
You can see when you switch into FBWA that the RCout goes steady but it would obviously not be in the correct direction due to the VIBES messing up the FC.

Thanks MBoland,
I will start by isolating the FC board.
Redo the testing and post the results.
Rui

You may also want to balance the prop/motor.

thanks!!
i will do my best to have the board not seeing vibrations.
Rui

Dear all,

I managed to decrease the amount of vibrations. Not sure if the level is now acceptable…

problems persist, mainly:

  1. auto tune, doesnt save pid values
  2. turns are toooo wide
  3. loiter mode… doesnt make any turn. flies straigh…
  4. in manual mode, it’s so touchy that i have to set expo = 100 and clip the max pwm value to 50%.

i’ve noticed that circle works pretty much alright.
even having my max bank angle set to 70%, i do not see the plane rolling more than… 25/30 degrees.
rolling is also assymetrical… (looks like)

in attachment you can have todays logs and the parameter file.

new problem… get power on the esc, i need to have the board connected to the laptop
if i just plug the batt there are no beeps coming from esc.
i can only get this beeps (and power to the esc/motor if the board is connected to the laptop…
(i suspect one of last weeks crashes may have damaged the board…)

thanks in advance for you help,
Rui



Hi Rui,
I’m on a similar path to you, researching arduplane for my first ardupilot build & I will be using an Omnibus Pro clone too.
So this comes from someone with the least amount of experience you could find … :slight_smile:
Firstly at least with the Omnibus clones (not sure about the original) the main controller is extremely sensitive to voltage levels, so it is wise to power servos from an external source (BEC / PDB) rather than from the board itself - in case a high servo load causes the processor to brownout. Not sure if this is contributing to your issues.
Also elsewhere on this site ( AutoTune woes. what am i missing?) there has been discussion that autotune on ardupilot was not saving parameters in versions 4.0.0 and 4.0.1 but should have been OK by 4.0.2 … so not sure if they didn’t hit target or if something has reverted with 4.0.3.
In any case it may be worth trying to save settings as Dave Glover said in above link by,

Performing auto tune. Land and disarm. Read the settings in mission planner then click write Params.

Good luck

Thanks Lex!
I bought a Pixhawk from BG. Hope it solves same of my problems.
Just dont know if it fits my S800 bay…
(I was not using an external BEC, that might have been one issue)
As soon as i have my new board I will try it and post results.
Cheers!!
Rui

Just a couple of notes…

  • the Omnibus controllers are very good for applications were redundancy of IMUs, etc is not required…unless you get a really bad clone (I have had 20 or so with 1 or 2 unreliable ones), to be sure you get a good one, buy an Airbot authorized source or a major supplier…that said, I get mine from BG or AliExpress, but only for my smaller models like z-84…for stuff packed with expensive gear like my MiniTalons, I dont use a BG/Ali sourced one.
  • NONE can supply a servo…always use the ESCs BEC or external BEC and isolate the power rail by removing a diode from the board as recommended in the wiki for that controller https://ardupilot.org/copter/docs/common-omnibusf4pro.html
  • I have not found them overly sensitive to vibration…but I do balance my props carefully and use a quality motor…that said…attaching with double sided sticky foam mounting tape provides decent isolation
  • Since you are moving to a Pix, I wont bother trying to help analyze the old logs…however, I do recommend you follow the wikis setup guide line for a basic FPV plane here: https://ardupilot.org/plane/docs/fpv-plane.html

how are your servos powered ? I have no problem powering the servos from the board. However, I have just fried two Omnibus F4 Pro v3 and two expensive receivers, consecutively, when the ESC BEC power lead is connected to the board while using 4s battery. No mods done on this particular board.

For my 6 other boards that are working, I have done this diode triplet ESC_5V Isolation mod on some of the boards, but haven’t really noticed much difference. I can remove the diode and the mid-ESC rail is still being powered by simply plugging in USB.
https://www.rcgroups.com/forums/show…C_5V-Isolation

my servos were powered directly from the board. and i did not do anything about the zener diode…

Servers by jDrones