Servers by jDrones

Omnibus F4 Pro V3 + FrSky R9 Slim+ and SBUS problem

Hi,

So i’ve bought a couple of new components of of AliExpress to make the transition from 2.4Ghz to 868Mhz via FrSky R9 modules.

The components:

  • Jumper T18 Pro
  • Omnibus F4 Pro V3
  • FrSky R9 Slim+ (flashed with the ACCST Flex firmware)
  • Yaapu Telemetry cable

The idea was to use Yaapu script on the Jumper T18 to receive telemetry information (via Smartport) but i stranded half way. Forget about telemetry right now, since i can’t even get SBUS working

This board (Omnibus) was first setup to use PPM (pad soldered and diode removed). I’ve re-soldered the pad so that it now is in SBUS mode.

From the documentation that I’ve read i learned:

  • Omnibus F4 has an uninverted SBUS connection
  • FrSky R9 Slim+ SBUS out is uninverted as well

So connected it all up, but no dice. In the radio tab of Qgroundcontrol no input from the radio.

Some more information which might be relevant

  • Jumper bonded successfully to the R9 Slim+. Although it seems to lose connection a lot. (green flashing: connection normal. red flashing: connection lost) Switches from approximately 50% green to 50% red
  • Connected several other wires to the Omnibus SBUS port to test out if that worked. The inverted SBUS and the SBUS In wires from the R9 Slim+. No success.

I’m obviously overseeing something. Or the board is broken.

Are there any debugging options available since i don’t know what my next step should be at this point.

Thanks.
Wim

I have several Quadcopter with an Onmibus F4 V3/V3 Pro/V5 + R9 Slim+/R9mm working. It is my favorite low cost combination for freestyle quads. SBUS should work out of the box. The solder jumper should set to PPM mode (not SBUS mode). The SBUS port of the FC should be connected to the uninverted SBUS_OUT on the R9MM and SBUS/OUT on the R9 Slim+. I never removed the diode as i don’t power any servos.

The TX and RX should always bind. It never looses the connection beside being out of range. The combination R9 Slim+ with the R9M Lite is very robust and stable. Range about 10km. I am using an older firmware version (v1.1.3).

Until now i did not get telemetry working robustly. I tried all combinations as tere are: external inverter, diode for hardware half duplex and software half duplex. It works if the FC is depowerd for a longer time. If i just change the battery telemetry stops working. There seems to be an electrical problem with the serial ports of the Omnibus. I never mind because i just use the OSD.

First I would get the binding between RX and the R9Slim+ working, then the rest should follow.

@THKoelnMech

Thank you for replying.

That would be my guess as well, first step. Setup binding correctly. I’ve Googled for older firmware of the R9 Slim to downgrade the current FW-R9Slim-ACCST_20190201 firmware but only FCC versions came up. I need the EU-LBT 868Mhz Flex firmware. Could you share your firmware file ?

At https://www.frsky-rc.com/r9-slim-plus/ -> Download -> ACCESS FIRMWARE you find version 1.2.0 dating 2020-01-16. I would try this first. The zip contains all LBT/Flex/Fcc versions. Be aware you need to update the transmitter to the same FW version accordingly. Both need to be identically. I have only FW 1.1.3 for the slim+ RX and the R9 lite TX. If you use the usual R9 TX module you would need the FW version 1.1.3 for this TX module.

If the connection problem is solved, try to reflash Ardupilot on the FC (maybe two times) using the betaflight configurator. I usually take the preflashed betaflight firmware and test if GPS/RX/ESCs/motor directions are working and correct.

@THKoelnMech

Ah, therein lies the problem. I’m using a Jumper T18 Pro with the built in 5-in-1 module which cannot use the ACCESS firmware. It has to use ACCST/Flex firmware

https://www.multi-module.org/using-the-module/protocol-details/frsky-r9

Btw, tried the ACCST EU-LBT version of the same FW-R9Slim-ACCST_20190201 firmware file. That doesn’t even bind. Only the Flex firmware does (but loses connection a lot)

OpenTX version: 2.3.8
Radio Module version: V1.3.1.13

Beginning to regret buying this radio since it has to jump through a lot of hoops to bind (especially) to FrSky receivers. FrSky R-XSR binding was no problem though.

From you name it seems you are from NL. I have a R9M lying around which i could send you (which of course also only supports ACCST and no ACCESS).

-> The RX and TX firmware version numbers and the style (FCC/Flex/LBT) need to be identical.

@THKoelnMech

That’s worth a shot. Can you contact me directly ?

Well. Got it working. It was as simple as updating the Multiprotocol firmware of the internal module

Which can be downloaded here:
https://github.com/pascallanger/DIY-Multiprotocol-TX-Module/releases

SBUS working. Now going for the S-PORT/Yaapu connection

-Edit: Yaapu S-PORT working as well

I have a similar problem (Can't get SBUS to work on Omnibus F4 Pro) so I’d like to understand correctly:

I your case, the underlying problem was the connection between the receiver and the transmitter, NOT the connection between the Receiver and the FC, right? Because that is my case, it would appear…

Should I maybe try the F.PORT connection my receiver offers? That apparently is uninverted…

Thanks!
Hajo

That’s right. The problem I’ve encountered was between de transmitter and the receiver.

What i did was solder the SBUS pad (not PPM) and leave the resistor in place. To the best of my knowledge the SBUS on the Omnibus is an inverted connection. Make sure your receiver supports that as well.

Servers by jDrones