Omnibus F4 Nano V6.1 mag is ok but GPS is not working (NO GPS)

I’m trying to setup and wiring my Omnibus F4 Nano V6.1 but on Mission Planner using firmware 4.1.0 I can’t get GPS working, I’m receiving “NO GPS” message, I tried to change baud rate of serial 3 to any other value even if my GPS working fine at 19200 on Betaflight. I connected GPS wires RX to TX6 and TX to RX6 on the back of the board and I have connected the magnetometer wires SDA and SCL (GPS/MAG combo) to the PPM and PB9 pins of the board as described on the wiring pic and even if the magnetometer is recognised and working I still get GPS not working. Is there any setting or wiring change I can do to get finally my GPS working too? After many trials it’s very frustrating when u can’t get GPS working your board, that’s why any help would be really appreciated.
I attached below the wiring scheme I followed.

Can you provide your parameter file? What GPS are you using and what are your GPS settings?

Thanks for your answer, as you asked I attached my parameter file and a pic pf my GPS details and wiring to FC. As I wrote my GPS Ublox Neo-M8N is working fine with Betaflight at serial baud 19200
Thanks again for your help
Nano.param (18.1 KB)

It looks like you have TX on the GPS connected to TX on the FC (and RX to RX). Try swapping the yellow and white wires on the FC.

Does GPS passthrough work? Can you connect to the GPS with uCenter? Do you see any GPS messages in Mavlink at boot?

You could also try setting GPS_TYPE to 1 (auto) or 5 (NMEA). Ideally I believe you would configure the GPS to output uBlox using uCenter so that Ardupilot can set the parameters, however.

I believe by default Ardupilot will try to auto-config uBlox GPS at 230400 baud. You can force it to fall back to 115200 baud by setting GPS_DRV_OPTIONS to 2.

I saw my wiring error just after take the pic and I swapped the TX/RX wires as u suggester but still no GPS. I cannot see any GPS message on Mavlink but only “EKF3 waiting for GPS config data” and also GPS_TYPE to 1 (auto) or 5 (NMEA) did not hep. Passthrough is not working but i can connect my GPS to Ublox center using a FT232RL FTDI USB adapter tool even if then I don’t know how to change GPS settings to make it work with AP, I hope you can suggest me a guide for these settings on uCenter. Opening GPS_DRV_OPTIONS when I click on the value field I get a new small windows where I can select “use baudrate115200” which automatic assigning a value of 4 to that field, I have to change that value to 2 as you suggested or I leave it at 4?
Thanks again for your help, it’s really appreciated

I think you would want to leave GPS_DRV_OPTIONS at 4 to use that option. The full parameter list I looked at didn’t have that listed as a bitmask.

Are there lights on the GPS? Are they on solid or blinking?

Is the magnetometer working currently?

Do you have something connected here? That looks to be an inverted pin on UART6, which if you had something connected could cause issues.

I’m sorry, I don’t know about bitmask, is there any setting to change or fix? There is nothing connected to the UART6 pin you circled in red. About GPS blue led, it’s solid at start but after a couple of minutes it start blinking like when 3D fix (GPS lock?) has been reached, magnetometer is detected as shown on the image attached below and I guess it’s working even if it’s not yet calibrated waiting to solve GPS issues first, but i see I cannot change the mag orientation because on that menu there is not any other option than “None”

Have you checked all of your solder joints? Some look kind of messy and could either be cold joints or shorted to neighboring pads. Probe with a multimeter to check continuity.

That inverted pin I circled looks like it may be shorted to the 5V pad next to it.

Failing that, have you tried another UART?

I checked twice all solders joints with a multimeter and there is no continuity between any pin not even on the inverted pin you circled which is not shorting to 5V pad. I will try to connect GPS to another UART then will let you know the result.

I tried to connect GPS to RX3/TX3 and changed BRD_ALT_CONFIG = 1 using RX3 / TX3 pins as SERIAL4 and I leaved SCA/SDL to PPM/BP9 like before, mag still detected but still NO GPS. :unamused:
Now I get the following error messages:

PreArm: Internal errors 0x80000 l:315 i2c_isr
PreArm: AHRS: EKF3 not started

I think that is an I2C error. Maybe the BRD_ALT_CONFIG isn’t working for some reason?

When you say this GPS was working on Betaflight, was it this same exact GPS and FC? If not, try flashing Betaflight (or iNav) on this FC and verify that it works. If it does, use uCenter via GPS passthrough to make sure the UBX protocol is enabled on the GPS and then try Ardupilot again.

Hi again, I flashed iNav and everything is working as expected (see screenshot) using the same hardware (FC and GPS/Mag combo). I will try to follow your advise to set up GPS on uCenter according your instructions. Thanks again

Do you have the GPS set to NMEA or uBlox in iNav? Is it on UART3 or UART6?

In iNav GPS is set uBlox and it’s connected to UART6 (the same pins of AP) @ baud rate 19200, magnetometer is connected to UART3 where RX3 = SDA and TX3 = SCL

Does it work if you set the GPS to 115200 baud?
Are Auto baud and Auto config enabled in iNav?

My GPS is working on iNav only at serial baud rate @ 19200.
See my GPS setting in iNav below:

set gps
gps_provider = UBLOX
gps_sbas_mode = AUTO
gps_dyn_model = AIR_1G
Allowed values: PEDESTRIAN, AIR_1G, AIR_4G
gps_auto_config = ON
Allowed values: OFF, ON
gps_auto_baud = ON
Allowed values: OFF, ON
gps_ublox_use_galileo = OFF
Allowed values: OFF, ON
gps_min_sats = 6
Allowed range: 5 - 10
inav_use_gps_velned = ON
Allowed values: OFF, ON
inav_use_gps_no_baro = OFF
Allowed values: OFF, ON
inav_w_z_gps_p = 0.200
Allowed range: 0 - 10
inav_w_z_gps_v = 0.100
Allowed range: 0 - 10
inav_w_xy_gps_p = 1.000
Allowed range: 0 - 10
inav_w_xy_gps_v = 2.000
Allowed range: 0 - 10

Type gpspassthrough in the iNav CLI, then follow the instructions here to setup uCenter. Either try resetting the GPS to factory defaults, or manually set the port to 115200 baud and UBX output as described below.

Finally, after followed your instruction, my GPS is working fine also with 3d fix just after a few minutes. I don’t want to take advantage of your kind help but my next issue is how to configure my SBUS receiver because I see my radio is not detected when I connect it by SBUS instead of PPM like before.
Thanks again for your support.

Great, I’m glad you got it working!

What receiver are you using? Can you take a picture of how it is wired to the FC? A parameter file would also be helpful to verify the configuration.

I have the same setup and the same problem since a year and half and i never got figured out! Stefano, can you confirm the issue is the default data rate of the GPS? So i can try the same fix