Servers by jDrones

Omibus F4 radio channels is empty!

Hi,
I have a problem with radio calibration on my Omnibus F4 and firmware ArduPilot.
I have controller Omnibus F4, radio receiver radiolink R6DS.
I solder PPM jumper and solder wire to RC channel and with firmware INAV raido is working!
But when i flashing Rover 4.0 or Copter 4.0.1 all radio channels is empty!
I try 3 different PPM sources, all 3 work great on INAV, and all 3 didn’t work on Rover 4.0!
Has anyone encountered such a problem, what to do?
Here a video: https://youtu.be/B5xIVecZ5Rs
p.s.: sorry for my English!!

The problem is partially solved.
I installed beta firmware for the Rover and the radio channels started working correctly!

1 Like

@Tsaryuk_Aleksey,

great that it’s working.

When you say “Beta” maybe you mean “latest”? If it was loaded using MP’s Install Firmware screen and “Beta firmwares” was selected then it should install Rover-4.0.0 which is the same as stable. If instead “latest” was installed (available by pressing “Ctrl-Q” or selecting the “All Options” on recent versions of MP) then I can easily imagine it would work better because we’ve found and fixed many issues as part of the Copter-4.0.x release.

We are planning on starting Rover-4.1.0 beta testing in the next month or so although a specific date hasn’t been set.

I download direct from https://firmware.ardupilot.org/Rover/beta/omnibusf4/

after installing the latest version (https://firmware.ardupilot.org/Rover/latest/omnibusf4/), I could not connect to the controller via MP. On the controller blink a led, as I understand it mavlink didn’t up.

I tried to reinstall stable version, and lastest again. And it doesn’t work for me!
I installed beta again, it works.

@Tsaryuk_Aleksey,

I’ve downloaded and compared “stable” and “beta” and as far as I can tell they are exactly the same firmware. They’ve been built using the same source code and the ardurover.apj files are identical. I wonder if perhaps something else has been changed in the setup or if the firmwares have been loaded using different methods?

Servers by jDrones