OK, I give up. Mapping Gimbal and Retract RC channels

I’m setting up my second pix system, but it is killing me. It’s exhibiting some random behavior that I can’t seem to figure out.

I have apm3.3 and trying to install

Tarot Retracts with retract controller
and Feiyu Mini 3d gimbal

Like I said, I’ve gotten some strange things going on.

For some reason, the gimbal will tilt with no problems. I simply can’t make it pan. And despite following setting the aux pins the way it says to on the apm site, I can’t get the retracts workin.

I had this all working on my other pix system just fine. So I know something is setup wrong with this one.

So I followed the wiki, put the retracts on channel 8. We’ll come back to them.

The gimbal are on aux1 & aux2. They’re set to my pots on channel 6 and 7.

I started out in MP by just going to the gimbal settings menu and setting things up. The tilt works like it should, but I get no panning. Switching channels didn’t get me anywhere. I know that the panning works, but the gimbal has different modes on it. I suppose that could be the problem?

I think I’m rambling and not making any sense here.

I guess the main question is, in order to get the aux pins to work. What settings should the rc9 and others be set at in order to control the gimbal?

Do I put them as pass through, gimbal control, disabled?

Does anyone know about the modes of this gimbal and if my problem is that I don’t have the mode switch hookedup and set to the proper mode?

It’s probably really simple and I’m just overlooking something from staring at it for so long.

I’m sorry if I’m not making much sense. It’s mid terms, I’m sick and running on a few hours of sleep. If I get frisky, I run out and play with this for a few minutes at a time. I’m really lost.

Thanks for any help!


Could you please post your .param file?

You said that you have tilt working. I’m trying to setup a tarot t2d gimbal ( two-axis ) to control tilt thorough pixhawk but no matter what it didn’t work.

Do you get tilt response after you power everything on or do you need to arm the copter to have response?

is the tilt connected to pixhawk aux port 1 ( first right port )?


You definitely shouldn’t use rc pass-through to control the gimbal.

Instead on the MP’s Camera Gimbal page set the Tilt and Pan section’s “Input Ch” drop-down to the transmitter channels you’re using (RC6, RC7 it sounds like).

The drop-downs beside “Til” and “Pan” should be set to RC9 and RC10. The “Stabilize Tilt” and “Stabilise Pan” check boxes should be unchecked.

Also assuming you’re using Copter-3.3, makes sure the “Type” drop-down at the very top is set to “Servo”. If you have to change it then remember to reboot the flight controller afterwards (i.e. unplug and plug back in again).

I’m currently on my phone. I’ll try to post the parameter file when I get back home.

I went to look and the “type” menu is greyed out on the gimbal screen. Would that have a part I’m this?

This thing is being odd. Here is the parameter file. I’m Honestly not sure how to
do that, so here’s a dropbox link.


I plug the tilt into aux1 and it tilts with the channel 6 pot

I switch it to aux2 and it still tilts, it just switches to the channel 7 pot

I plug the yaw into either one, and it won’t move.

I’m thinking it’s got to be the gimbal? It has different modes. I’m wondering if I don’t have it locked into the “heading Lock” mode where it won’t yaw?

I’m going to go look at that in the meantime.


Please thank you of having posted your param file. I was able to figure out that the parameter BRD_PWM_COUNT was set to 0 in my board. I have changed it to 4 and now my gimbal is working nicely!

I think the way it was, none of the pwm output ports were working…

Regards, Fernando

ok, that’s an odd problem, never seen that before! Sorry I was unable to help but great that you and smocksam figured it out.
I’ll close this issue if that’s ok.

For me, Fine ! It was probably my fault messing up with the parameters… Thanks for your help!

Regards, Fernando