Odd step up in RPM on new motor test

Today I tested the first of my new Mad Components 5110-eee motors - using BLHeli_32 and BD-Shot.

I was just testing for motor direction - and RPM signal integrity.

The motor makes an odd step up in RPM when started. It’s both audible, and visible on the RPM graph in the Mission Planner Tuning screen.

I can’t tell if this is a normal behavior, or something not working properly.

Here’s my BLHeli_32 setup:

Here’s the BIN file from my tests. (I enabled logging while disarmed.)

And here’s a YouTube video that displays the RPM step up behavior.

I’d appreciate any and all comments. Thank you!

Was the Rampup Power at 15% by default?

Good question.

No - the default was much higher.

According to the tuning guide I’ve used, larger props take lower ramp-up power. (I plan to use 22” props)

I could adjust it to test it. I don’t remember the exact setting I used on my 690 class quad with 15” props, but it was in this neighborhood.

Come to think of it - since I was only testing for rotation direction with the props off, maybe this ramp up setting is too low for no props.

Thanks Dave, for taking such a close look. I’ll let you know what I find out with a higher value.

BTW - here’s the BLHeli_32 tuning advice I tend to follow: Tuning your ESC (BLHeli_32) to stop desyncs and improve motor performance in your FPV quadcopter! - YouTube

The rampup power should only affect performance for startup → stationary then to idle MOT_SPIN_ARM and maybe to MOT_SPIN_MIN too.
There’s some evidence it may effect a bit more, but it’s not solid evidence and the BLHELI doco doesnt support that.
Maximum Acceleration will affect BLHELI performance across the whole range.

I think what you are seeing is that rampup effect, since it is evident in the RPM but not in the commanded throttle. Set rampup to 25% at least, until you have a requirement to lower it.

Yea, 50% most likely. I have used that (default on most I think) down to 320kV motors with no problem. Actually I haven’t fussed much with Blheli_32 settings on any craft other than the obvious (low rpm power protect). I tend to disable Sine Modulation only so variable PWM is enabled.

@dkemxr @xfacta

Raising the ramp up power has corrected the issue.

But even set at 50%, the default, there’s still a faint audible “click” when doing the motor tests at 10%. The RPM graph however shows no “step” in rpm.

I’m wondering if this is perhaps a “feature” not a “bug” - and I’ll investigate further with the BLHeli_32 experts.

Meantime - I’ve got Ramp Up set to 40%. I’ll report back if I’m able to find more to this story.


@xfacta @dkemxr

By copy to @andyp1per - you may find this interesting -

I reached out to Steffen Skaug (the fellow who wrote BLHelli_32) about this. His reply was interesting in informative. Looks like the odd behavior I noticed is a “feature” not a “bug.”

The option Steffen suggests of “on adaptive” for the Low RPM Power Protection option is new with the latest BLHeli_32 firmware - 3.9. A reference to the options can be found here:

So with this information I’ve set the Ramp Up parameter down to 20%. I could probably go lower, but without a test bench, I’d hate to put this copter at risk. I’ve used 20% on my 690 class quad with 16" props - no problem so far.

Yes, Low RPM Power Protect = Adaptive is fairly new.
Rampup Power wont affect flight.

Fairly new? I think “on adaptive” new with the last firmware release.

My understanding of Ramp Up power comes from this explanatory video:

But this video has a little different take on the topic:

1 Like

I believe both those videos are slightly wrong - especially concerning a larger copter like we are typically using. When was the last time a copter with 18inch props went from zero throttle to full throttle in an instant and the only thing we were worried about was the flight characteristics? :slight_smile: Sorry that comment didnt quite fit the argument, but you get what I mean - we’re not doing acro with your copter, and the throttle changes will be incremental.
Interestingly both of those videos leave out maximum acceleration.

The rampup power is just for zero RPM up to a working RPM - which obviously is going to affect very small acro quads where they are likely to have idle RPM or no-RPM to full RPM changes many times per flight.
Once one of our (larger) copters are flying RPM is not going below MOT_SPIN_MIN which should be well out of the range of ramup power interference.

We can typically use lower rampup power to help tame yaw oscillation at arming, particularly if you have very long/high landing gear.

Once motors are turning reliably (as discovered by the rampup power process) Maximum Acceleration is the setting that comes into play.

I think you’re referring to motor rpm “acceleration” as the motor phase where Ramp Up comes into play.

The question I have is how the “micro” changes in motor rpm as the PID loop achieves the target aircraft attitude, show up as motor acceleration affected by Ramp Up.

If this is the issue - then our quads are similar to FPV quads, except that they’re operating at higher RPM due to prop size.

I think it might be worth another question to Steffen Skaug. I’ll report back with his response.

Normal flight won’t be affected by rampup, only spin up to ARM or maybe MIN. With our copters, and yours in this specific case, we are never going back to such a low throttle or RPM that rampup mode would be invoked (until disarm). Small acro quads could do that frequently.

When I mentioned acceleration in this discussion I’m referring to the BLHELI acceleration setting, which would operate over nearly the entire motor RPM range.

EDITs for poor phone typing

I still think your Rampup Power could be default (50% I think??). I’ve only gone down to about 25% when I was chasing a yaw oscillation at arming. But there will be no harm in having it lower than default provided you still get reliable/smooth start of motors at arming.
It’s not going to affect flight, according to what Steffan says and the way the doco reads.