OctoQuad with Opto ESC's power problem

I have just got my Pixhawk2.1 and mounted all 8 opto ESC’s to the “Main out” and a powermodule to Power1 input.
PH2.1 seems to startup just fine, but all the engines beeps. FrSky X8R reciever is powered connected to RCin and working.

Do i need to power the Main-out rail? How can i possible do that when all 8 connectors are in use ?
Any other suggestion to my problem?


You haven’t given any detail of HOW you hooked things up.
A pic?
More detailed description?

If the ESC’s are beeping then they are not getting signal.
Have you pressed the safety switch?
There will be no signal out until you press the safety switch.

There is nothing more than already explained above except for the gps connected to gps1 input.

I have tried pressing the saftey switch on the gps without any result.

Will the engines be beeping before the safety switch is pressed ? Haven’t seen that on my previous pixhawk’s.

yes, opto esc need power, you can per the rail through aux ports and main ports, do not power rc in or sbus

Hi IJustWant,

I think I had a similar problem (minus the beeping) with my last build.

It turned out that I had forgotten to power the ESCs , just as seems to be the case for you.

The issue is that the servorail does not provide power itself from within the pixhawk.

There are two options:

  1. Power the servo rail via one of the aux ports
  2. Create some kind of mini power distribution board for +5V, power that from your BEC and then plug the red and black wire from your ESC into there (keep the white cable plugged into the pixhawk of course for signal).

Option 1) is very simple
Option 2) is some work, but has the advantage that you have less cables connected to your pixhawk, which potentially reduces to vibrations that are transferred (via the cables) to your pixhawk.

Just thinking - an even simpler issue could be that you have plugged in the ESCs cables “upside down” maybe?

Hope this helps, good luck

P.S: A pic might help…

I’ll add that the 2.1 IMU are internally dampened so wore vibration should not be an issue. And be sure to do the service on ch1 before using it. install a beta version of MP to be sure the service issue applies, but I don’t think any are available where it foes not yet