Octocopter with Motor vibrations, but only in Loiter


I have a problem with one drone, that I can´t figure out. It is a octocopter, with orange cube 4.1.1 and 17" propellers.

We use this kind of drone very often, works always fine so far. But with this one, when I switch from Althold to Loiter in the air, some motors do start to vibrate. I will try to make a video next time. If I switch back to Althold, the vibrations are gone immediately. We already switched Cube and ESC´s, no change. I tried today instead of Loiter Poshold, no vibrations here.

Could someone please take a look at the logfile, maybe I´m missing something?


When you switch from Althold to Loiter, is there any change in vehicle behavior? e.g. are you moving around in Loiter, but not in Althold?

When you tried Poshold, did you also try Loiter in the same go?

A picture of the drone might also help debug vibrations.

Despite the vibrations, the drone still behaves the same and holds the position. I move around also in Althold. I will try to make a video of it tomorrow, so you can better see what kind of vibrations are present.

I changed in the settings the flight mode from loiter to loshold on the ground, but did not switch it in the air from poshold to loiter.

Following this issue.

Vibrations look reasonable, no problem there.
Pitch and Roll attitude control is very good. Yaw is the odd one out - probably a yaw Autotune would help.
There could be some some benefit to setting up the Harmonic Notch Filter too, these should work OK for a starting point on Cube Orange
Refresh parameters after setting the enable params in order to see the rest.

I dont see any motors being commanded to minimum while in flight, all motors are very consistent.

You are switching between AltHold and Loiter a lot, and Simple Mode could be confusing the issue too. Probably avoid simple mode until behaviour is correct. No need for POSHOLD mode either, Loiter does a better job and is more configurable. Just be ready to select Stabilise if something ever goes wrong.

Do another test flight to gather data for the Harmonic Notch Filter (use the params above) and just do some hovering in AltHold and gentle movements including yaw.
Let’s see that .bin log file.

You could try setting these too, they should be safe and might help to fix the issues (which I couldnt really see in the log)

Hello Shawn,
thank you for the feedbacck. For the Notch Filter, it was enabled in the first flight, but had there also the same problem and deactivated it in the next flight.

I will try Autotune for Yaw, when the weather is better. I made this Video here, to showcase the vibrations. They only come in Loiter and as you can see, as soon as I switch to Althold and they are gone, you can see this very clearly at the last 20sec. of the video.


Hello Shawn,

I would like to thank you again for the help, we did the autotune for YAW today and could make one flight after it. It did not show the vibrations anymore, if you have time, maybe you can take a look at the logfile.


I will test it tomorrow more and also enable the Notch Filter again.

That is good attitude control tuning without the Harmonic Notch Filter. I would still set it up.

You are missing some fairly critical battery related parameters and motor/battery scaling.
Connect to MissionPlanner, press Alt A and step through that dialog, then select all the params related to a voltage (deselect any others) and apply them.
Then also set: