Octo-x copter tuning - am I missing something?

I am seeking community assistance tuning an octo-x copter. I flown it a few times. I’ve tried to make changes to improve flight characteristis but I’ve only made things worse. Last flight ended with a very hard landing. I’ve read many posts several times, but I must be missing something. Below are the specs and information about the copter.

I’ll update the firmward to the latest version before atempting another flight. Thank you for having an interest. Sincerely - Seth


  • 1600mm Octo-x copter, carbon fiber frame (unknown manufacturer)
  • 28 inch non-folding carbon fiber props (unknown manufacturer)
  • HobbyWing Xrotor HV Pro 80A speed controllers
  • outrunner motors (unknown manufacturer)
  • two 6s 22,000 mah lipos in series (44 volts)
  • orange cube on ADS-B Carrier Board
  • Here3 GPS
  • Herelink radio
  • Batt monitor & power supply
    • Mauch 024 – PL 4-14S HYB-BEC – 2 x 5.3V & 1 x 12.0V
    • Mauch 004 - PL-200 Sensor Board
  • All up flying weight 43 lbs (19.5 kg)
    • Copter 32 lbs
    • Batteries 11 lbs

I set up a simple fixture so I could measure prop thrust. I recorded voltage and current using the onboard Mauch sensor. I actuated a single motor using Mission Planner → Initial Setup → Motor Test. I tested the motor for 15 sec starting with a throttle % of 10 stepping to 100 in increments of 2. The raw data is in column A, B, C, and D of this google sheet. I tried to transform the equations so it would give the same results as pwm values but I’m not sure I was successful.

Below are three flight logs. Parameter settings are slightly different for each flight.

Hello @SethNC

Try enabling Notch Filter before tuning it, it should help with large copters.

Those long arms and large props look suspicious to me. They could be quite flexible (or maybe not).
This can be a problem with Octos - you cant use large props without going to enormous frame diameters.
Some of XM2’s large custom built heavy lift frames used the Quad-X8 format and even had double arm tubes for strength - we can’t all afford to do that though.
But anyway…

I would change these:
FFT_MINHZ,40 or 60

There’s a lot of oscillation, and your PIDs look very low. The log with higher rate values has smaller but higher frequency oscillations.
Based on that I’d be inclined to try:

Take off and check for oscillations, follow the tuning guide from then on to gain stability to a point where you can run Autotune. Feel free to supply more .bin logs.

Maybe AUTOTUNE_AGGR,0.07 for a start.

1 Like

@BrunoBagarini and @xfacta thank you for the replies and info. I appreciate the direction and link. I’ll change the parameters as suggested. I’ve set the project to the side for a few weeks so maybe when I revisit the Tuning Process Instructions — Copter documentation I will follow it better. Appreciate the help. I’ll post .bin log of the next flight.

1 Like

GREAT success!! Copter flew well in STABILIZE with the new parameter settings listed above from xfacta. When in ALT_HOLD flight mode the copter was not able to maintain altitude without additional throttle input.

A link to the flight log is below. The copter seemed stabile enough to me for AUTOTUNE once I get the ALT_HOLD figured out. Thanks for any help understanding the issue. Thanks - Seth

2022-08-23 19-59-44.bin

Flight Video (VID 20220823 195813495 - YouTube)

MOT_SPIN_MIN,0.18 is quite high and encroaching on effective attitude control
Can you push down MOT_SPIN_ARM to as low as possible and still get reliable startup of motors at arming, then add 0.03 to get MOT_SPIN_MIN
example: MOT_SPIN_ARM = 0.10 so set MOT_SPIN_MIN = 0.13
Alternatively, add some dummy payload to force up MOT_THST_HOVER - it must be well fixed and not able to vibrate or move.

Set these and try hovering in AltHold mode for a while

I would also set
for safety, you dont want this thing getting away

Thanks again @xfacta. I should be able to try these adjustments tomorrow.

Update. My issue with ALT_HOLD not maintaining altitude was not with the cube parameter settings. The copter was doing what it was being told by the HereLink controller. My issue was I had selected “Throttle Cent 0” on the transmitter. I corrected this and ALT_HOLD is working as expected. I figured this out when I tried to get the copter to descend quicker by giving it down throttle and it maintained the same descent rate.

I would not have gotten this far without the help from @xfacta! Thanks a million.

More information on this can be found at the cube pilot / Herelink website.

I had made progress with this big copter, but . . . it’s still not right.

I have performed an AUTOTUNE for roll and updated this for both roll & pitch. However, I’m not sure if I have too much noise for the flight controller or too much flex in the frame or something else. Attached is a short flight .bin log. I looked at the FFT noise with MAVExplorer and attached the gyro & accel graphs. Thanks again for direction. - Seth


2022-08-29 20-47-37.bin